Results 1 to 5 of 5

Thread: [...] but it is not going to be installed

  1. #1
    Join Date
    Feb 2011
    Beans
    2

    [...] but it is not going to be installed

    Hi everyone

    I have the following problem: I want to install anthy (an input method for Japanese text) on my laptop, running with eeebuntu 4 (with upgrades).

    When I tried to do this with synaptic, I recieved the error message "Depends: libanthy0 but it is not going to be installed". So I installed libanthy0 manually (along with anthy-common, on which libanthy0 depends); but when I tried again to install anthy afterwards, I recieved the message "to be removed: anthy-common, libanthy0" and then "Depends: libanthy0 but it is not going to be installed" again.

    When I try to install anthy using apt-get, I get the following output:

    > sudo apt-get install -f anthy
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    anthy: Depends: libanthy0 (= 9100h-3) but it is not going to be installed
    E: Broken packages


    From > sudo apt-get install libanthy0 I get

    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    libanthy0 is already the newest version.
    0 upgraded, 0 newly installed, 0 to remove and 191 not upgraded.


    Removing libanthy0 and reinstalling it via apt-get hasn't changed anything.

    Does anyone know how to solve this problem? (I have tried to find it on this page and with google, and although I have found several similar posts, the solutions seemed rather specific to me and didn't help. Still, I'm sorry if I'm asking something that has already been answered somewhere.)

    I would appreciate any help!

  2. #2
    Join Date
    Dec 2008
    Location
    Northwest Ohio
    Beans
    1,581
    Distro
    Lubuntu 13.10 Saucy Salamander

    Re: [...] but it is not going to be installed

    Hi,
    Try using these commands to see if it helps:

    Code:
    sudo apt-get install -f
    sudo dpkg --configure -a
    Now try installing anthy again after reloading your repositories:

    Code:
    sudo apt-get update
    sudo apt-get install anthy
    Hope this helps.

  3. #3
    Join Date
    Feb 2011
    Beans
    2

    Re: [...] but it is not going to be installed

    Dear Ankspo71

    thank you for your quick reply! Your suggestion didn't work exactly like that, but after I added the debian unstable repositories it worked.

    Thank you!

  4. #4
    Join Date
    Sep 2011
    Beans
    2

    Re: [...] but it is not going to be installed

    Why does it say "SOLVED" on the top. very confusing!!

  5. #5
    Join Date
    Jun 2007
    Location
    K-o-T,
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: [...] but it is not going to be installed

    Quote Originally Posted by safwanlmu View Post
    Why does it say "SOLVED" on the top. very confusing!!
    Did you read the post above yours

    but after I added the debian unstable repositories it worked.
    Hypertension = Take with a pinch of salt
    | Psychocats | Ubuntu Documentation | Howto [Solved] | BBcode list | Brother Website |

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •