Results 1 to 10 of 10

Thread: enable network card at boot

  1. #1
    Join Date
    Sep 2008
    Beans
    5

    enable network card at boot

    I am using backtrack 4 which is basically ubuntu 8.04.
    I have set my NIC and it is working okay, but this distro does not enable NIC at boot time for some security reasons.

    what should I do so the system would boot with NIC enabled and running? after every single boot I have to go 'ifup eth0' to get it working.

    I want a command line solution, please. adding a module? if yes, how? I am really stuck.

    I want NIC to enable on boot not on user logon so I will be able to connect remotely through SSH in case the machine reboots for no reason (like power cut-off).

    thanks!!

  2. #2
    Join Date
    Sep 2009
    Location
    In a cold, dark place
    Beans
    186
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: enable network card at boot

    Code:
    sudo vim /etc/network/interfaces
    add the line

    Code:
    auto eth0
    save, close, restart networking

    Code:
    sudo /etc/init.d/networking restart
    That should do it

  3. #3
    Join Date
    Sep 2008
    Beans
    5

    Re: enable network card at boot

    nope it doesn't, I have auto eth0 line in there but my eth0 does not come on automatically

  4. #4
    Join Date
    Nov 2007
    Location
    Okieville, USA
    Beans
    3,178
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: enable network card at boot

    Quote Originally Posted by gybe View Post
    I am using backtrack 4 which is basically ubuntu 8.04.
    I have set my NIC and it is working okay, but this distro does not enable NIC at boot time for some security reasons.

    what should I do so the system would boot with NIC enabled and running? after every single boot I have to go 'ifup eth0' to get it working.

    I want a command line solution, please. adding a module? if yes, how? I am really stuck.

    I want NIC to enable on boot not on user logon so I will be able to connect remotely through SSH in case the machine reboots for no reason (like power cut-off).

    thanks!!
    Maybe use the real Ubuntu? I've tried a lot of Ubuntu's "children" and none work as good as Ubuntu.
    MCP, A+/Linux+ Certified IT Technician
    System Specs | Dress up your "Super Button" FREE
    "If sometimes you can't be good, then be VERY good at being naughty!"

  5. #5
    Join Date
    Sep 2009
    Beans
    41

    Re: enable network card at boot

    I have played with backtrack. I don't like it.
    In my opinion you are better of grabbing a copy of linux mint and adding in the security scripts you need but since that is unreasonable for most backtrack users:

    http://ubuntuforums.org/showthread.php?t=53700

    That might help out. If not... Then let us know.

  6. #6
    Join Date
    Sep 2008
    Beans
    5

    Re: enable network card at boot

    it's just that backtrack has networking disabled at boot because it is not wise to request for an address from DHCP, that's all. so if it's disabled there's surely some way to enable it back up.

  7. #7
    Join Date
    Sep 2009
    Beans
    41

    Re: enable network card at boot

    Quote Originally Posted by gybe View Post
    it's just that backtrack has networking disabled at boot because it is not wise to request for an address from DHCP, that's all. so if it's disabled there's surely some way to enable it back up.
    http://ubuntuforums.org/showthread.php?t=172173

    ^some *dirty* stuff you can try^
    ps adding ifup eth1 to /etc/network/interfaces won't work afaik

  8. #8
    Join Date
    Sep 2008
    Beans
    5

    Re: enable network card at boot

    it's working now that I have put it into rc.local file, but at the moment I'm already writing a script for eth0 startup for init.d.

    damn I just never get bored of finding 100 solutions to a problem

    thanks anyone, links helped me a lot

  9. #9
    Join Date
    Apr 2012
    Beans
    1

    Re: enable network card at boot

    adding the single line "auto eth0" to /etc/network/interfaces didn't worked for me either. but adding these two lines worked:

    Code:
    auto eth0
    iface eth0 inet dhcp

  10. #10
    Join Date
    Oct 2004
    Location
    Denmark - Scandinavia
    Beans
    17,619
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: enable network card at boot

    Old thread, please start a new thread.
    elementary OS Luna
    My Screenshot

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •