Chuck I first tried with pacmanXG and again with yaourt and it complains about wayland and wayland-git are in conflict,
Even Precise says broken packages when trying to install weston, Im lost !