Results 1 to 2 of 2

Thread: wpa_supplicant will not connect

  1. #1
    Join Date
    Mar 2010
    Beans
    20

    Unhappy wpa_supplicant will not connect

    I have been attempting to get wpa_supplicant to work so that it automatically connects to my wireless network (ie when the machine starts, before I log in)
    I have been following the guide at https://help.ubuntu.com/community/WifiDocs/WPAHowTo
    which gave me the command
    Code:
    sudo wpa_supplicant -iwlan0 -c/etc/wpa_supplicant.conf
    and the wpa_supplicant.conf (substituting L for letter and N for number for security reasons
    Code:
    # reading passphrase from stdin
    network={
            ssid="LlllllLNLNLn"
            #psk="NNNNLNNLNNNN"
            psk=NNNNllNNNNlNNNlllNNNLNNNNNLLNLnnnnnlnnnnnnnnnlnlnnnnnllnlnnlnnnn
    }
    which was generated by running
    Code:
    sudo wpa_passphrase LllllNLNLN > /etc/wpa_supplicant.conf
    however when I try to connect with
    Code:
    sudo wpa_supplicant -iwlan0 -c/etc/wpa_supplicant.conf
    I just get the message
    Code:
    Trying to associate with 00:01:e3:f0:a2:d8 (SSID='OrangeF0A2D6' freq=2437 MHz)
    Associated with 00:01:e3:f0:a2:d8
    CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
    ioctl[SIOCSIWSCAN]: Device or resource busy
    Failed to initiate AP scan.
    infinately untill I press Ctrl+C

  2. #2
    Join Date
    Jul 2011
    Beans
    5

    Re: wpa_supplicant will not connect

    Not sure if you ever resolved this. I removed network-manager and it worked

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •