Results 1 to 4 of 4

Thread: HFS+, disabled journaling, still can't r/w

  1. #1
    Join Date
    Oct 2008
    Beans
    55

    HFS+, disabled journaling, still can't r/w

    I swear I disabled journaling - I opened up disk utility in OS X and clicked DISABLE journaling. But when I try to mount it in Ubuntu, I get :


    Mar 20 06:31:02 jakc-laptop kernel: [ 1510.743691] hfs: write access to a journaled filesystem is not supported, use the force option at your own risk, mounting read-only.


    Do I need to re-format and re-partition the hard drive from scratch in order for Linux to believe that its not journaled?

    Also, when I browse the hard drive, I can look at most folders, but others (my iTunes folder, for example) are inaccessible.

  2. #2
    Join Date
    Aug 2005
    Location
    Huntsville, AL, USA
    Beans
    7,526
    Distro
    Ubuntu

    Re: HFS+, disabled journaling, still can't r/w

    Quote Originally Posted by jackbusch View Post
    I opened up disk utility in OS X and clicked DISABLE journaling.
    That sometimes happens. Use the command:

    Code:
    diskutil enableJournal /Volumes/TheVolumeName
    to enable it again, then disable with:
    Code:
    diskutil disableJournal /Volumes/TheVolumeName
    then try again.

    Quote Originally Posted by jackbusch View Post
    Also, when I browse the hard drive, I can look at most folders, but others (my iTunes folder, for example) are inaccessible.
    that is a permissions issue. Linux respects the set permissions of files and folders on HFS+ volumes. your Ubuntu user does not "own" those files, and the permissions are set to disallow access to those that do not own them. Boot into OSX and place files in a different location that has full access, or change the permissions of your music folder to allow access to others.

  3. #3
    Join Date
    Oct 2008
    Beans
    55

    Re: HFS+, disabled journaling, still can't r/w

    Ah, okay - well, Ubuntu still thinks its journaled. But that's okay because now I can at least read from there (thanks to the permissions tip) which is what I really wanted. Thanks!

  4. #4
    Join Date
    Oct 2010
    Beans
    10

    Re: HFS+, disabled journaling, still can't r/w

    I disabled journaling as well, but I'm finding with every reboot, I need to restart into OSX, enable journaling, and then disable it again. There has to be a better solution. Perhaps a way to disable journaling from Ubuntu?

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •