have tried new 32-bit VIA Chrome driver on the nc20 with ubuntu 11.04

I get with kernel 2.6.38-13-generic:
Code:
# modprobe via_chrome9
FATAL: Error inserting via_chrome9 (/lib/modules/2.6.38-13-generic/updates/dkms/via_chrome9.ko): Invalid module format

# dmesg | tail
...
[  168.797431] via_chrome9: disagrees about version of symbol module_layout
But driver seems to work with old kernel 2.6.35 from Ubuntu 10.10 but Xorg crashes with SEGFAULT when it used