I just unboxed my new dell latitude 2120. It came with 10.10 installed. I want to upgrade to 11.04 (and perhaps to 11.10 if possible).

When I click on the "upgrade" button in update-manager, i receive this error
Code:
Authentication failed  Authenticating the upgrade failed. There may be a problem with
I have tried the libreadline.so.6 trick in http://ubuntuforums.org/showthread.php?t=1711179 by downloading the latest libreadline from gnu, make, make install. It turns out to be libreadline.so.6.2 that i compiled and it stored it into /usr/local/lib by default. I try update-manager again and still run into the same issue.
Code:
Authentication failed  Authenticating the upgrade failed. There may be a problem with
I've tried typing in
Code:
gpg
I got the following error:
Code:
gpg: symbol lookup error: /usr/local/lib/libreadline.so.6: undefined symbol: PC
I guess the libreadline.so.6 is just a pain. What other fixes are there?