Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: .gvfs error while accessing home directory

  1. #1
    Join Date
    Apr 2011
    Beans
    79
    Distro
    Ubuntu 10.04 Lucid Lynx

    .gvfs error while accessing home directory

    I installed Xubuntu 11.10 but I keep on getting this annoying bug. Whenever I try to access the home folder I get a popup that says...
    Code:
    Failed to open directory "nethero"
    
    Error starting file '/home/nethero/.gvfs
    Transport endpoint is not connected
    I can solve this by using umount to unmount .gvfs but the bug keeps coming back. I access my home folder all the time. Is there a permanent fix for this?

  2. #2
    Join Date
    Nov 2008
    Beans
    Hidden!

    Re: .gvfs error while accessing home directory

    My .gvfs is empty. What do you have in yours? Try renaming .gvfs and see if the folder will regenerate.

  3. #3
    Join Date
    Dec 2009
    Beans
    5,339

    Re: .gvfs error while accessing home directory

    I do not know the answer to the original problem but I would not rename ".gvfs". It's where the system mounts remote shares ( Samba, ftp, ssh, etc ... )

  4. #4
    Join Date
    Oct 2005
    Location
    Milano, Italy
    Beans
    864
    Distro
    Ubuntu Jaunty Jackalope (testing)

    Re: .gvfs error while accessing home directory

    Quote Originally Posted by Morbius1 View Post
    I do not know the answer to the original problem but I would not rename ".gvfs". It's where the system mounts remote shares ( Samba, ftp, ssh, etc ... )
    Can you show your fstab?
    Code:
    cat /etc/fstab
    Just as consideration: it is probably wrong to have mount point under your home dir.
    ------------------------------------------------
    yep ”short and long URL„
    http://yep.it/
    ------------------------------------------------

  5. #5
    Join Date
    Dec 2009
    Beans
    5,339

    Re: .gvfs error while accessing home directory

    Quote Originally Posted by dentaku65 View Post
    Can you show your fstab?
    Code:
    cat /etc/fstab
    Just as consideration: it is probably wrong to have mount point under your home dir.
    If that question was directed to me the system does not place the mount instructions in fstab for remote shares.

    When you use "Network" or "Connect to Server" the system creates the mount point in the user's home directory within the .gvfs subdirectory automatically.

  6. #6
    Join Date
    Nov 2008
    Beans
    Hidden!

    Re: .gvfs error while accessing home directory

    Quote Originally Posted by Morbius1 View Post
    When you use "Network" or "Connect to Server" the system creates the mount point in the user's home directory within the .gvfs subdirectory automatically.
    so it will regenerate

  7. #7
    Join Date
    Oct 2005
    Location
    Milano, Italy
    Beans
    864
    Distro
    Ubuntu Jaunty Jackalope (testing)

    Re: .gvfs error while accessing home directory

    Quote Originally Posted by Morbius1 View Post
    If that question was directed to me the system does not place the mount instructions in fstab for remote shares.

    When you use "Network" or "Connect to Server" the system creates the mount point in the user's home directory within the .gvfs subdirectory automatically.
    Ok. Can you post the output of:
    Code:
    ls -alirt ~/.gvfs
    Or just recreate .gvfs
    Code:
    mv ~/.gvfs ~/.gvfs.original
    Then connect your remote resources
    Last edited by dentaku65; January 18th, 2012 at 07:10 PM.
    ------------------------------------------------
    yep ”short and long URL„
    http://yep.it/
    ------------------------------------------------

  8. #8
    Join Date
    Dec 2009
    Beans
    5,339

    Re: .gvfs error while accessing home directory

    @nethero,

    It appears that you are the victim of an almost 4 year old bug:
    https://bugs.launchpad.net/ubuntu/+s...fs/+bug/212789

    You will note that there was an additional comment on that just 3 weeks ago. The workaround as noted in that bug report is to do exactly what you have been doing and that is to unmount the .gvfs folder. I have never experienced this myself and it's not even clear to me from your particular description that there is anything to unmount yet the unmount does resolve it - at least for the moment.

  9. #9
    Join Date
    Apr 2011
    Beans
    79
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: .gvfs error while accessing home directory

    Quote Originally Posted by Morbius1 View Post
    @nethero,

    It appears that you are the victim of an almost 4 year old bug:
    https://bugs.launchpad.net/ubuntu/+s...fs/+bug/212789

    You will note that there was an additional comment on that just 3 weeks ago. The workaround as noted in that bug report is to do exactly what you have been doing and that is to unmount the .gvfs folder. I have never experienced this myself and it's not even clear to me from your particular description that there is anything to unmount yet the unmount does resolve it - at least for the moment.
    Ah. Thank you. I did umount it a couple of times but it kept coming back when I rebooted. I read that it was related to encrypting the home folder so I reinstalled but I did not choose the option to encrypt the home folder. So far no error message. I will mark the thread solved even though this bug still exists.

  10. #10
    Join Date
    Sep 2010
    Location
    Ottawa, Canada
    Beans
    58
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: .gvfs error while accessing home directory

    Bug still exists in Xubuntu 12.04. Using Thunar will result (sometimes) in not being able to see any of the files in your home directory due to the error in reading the hidden .gvfs folder. The workaround to quickly fix this temporarily (4+ years old bug), is to use:

    Code:
    sudo umount ~/.gvfs
    Using this command from a terminal will enable you to browse your home directory again using Thunar.
    "Basically what Ubuntu says is that we don’t make sense alone as human beings...we are only fully human and only fully able to live, to flourish, to function, all of those things, in a community. I am what I am because we are."

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •