Results 1 to 4 of 4

Thread: Backup files ending with ~

  1. #1
    Join Date
    Nov 2010
    Beans
    10

    Backup files ending with ~

    Hi All,
    just a simple problem here. I go the terminal and list all the files in a folder where some of my files exist, e.g. Desktop.
    For some files and even desktop shortcuts, there exists another copy that ends with ~. Now, I can't figure out what application is making these files but I'd love to disable it. Any help please?
    UBUNTU 11.10
    Thanks in advance!
    Last edited by possumkeys; January 18th, 2012 at 08:46 AM. Reason: Stated ubuntu10.10 instead of 11.10

  2. #2
    Join Date
    Nov 2011
    Location
    /dev/root
    Beans
    Hidden!

    Re: Backup files ending with ~

    The tilde (~) backup file style comes from Unix. For example the editor emacs creates tilde backup files. I think you must figure out what software you are using and test if it creates such backup files.

    Sometimes it is very valuable to have such backup files but to get rid of them you need to find what application creates them.
    Last edited by sudodus; January 18th, 2012 at 09:21 AM. Reason: improved grammar

  3. #3
    Join Date
    Feb 2005
    Location
    Melbourne, Australia
    Beans
    13,510
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Backup files ending with ~

    Quote Originally Posted by sudodus View Post
    The tilde (~) backup file style comes from Unix. For example the editor emacs creates tilde backup files. I think you must figure out what software you are using and test if it creates such backup files.

    Sometimes it is very valuable to have such backup files but to get rid of them if you find what application creates them.
    Gedit, even OO used to IIRC. Mostly the issue comes under the heading "Big deal".
    Regards, David.
    Please use the Forum search and Wiki search for immediate help
    Please mark your thread as Solved when appropriate
    New to technical forums?: How To Ask Questions The Smart Way

  4. #4
    Join Date
    Apr 2005
    Location
    Finland/UK
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Backup files ending with ~

    ...and keep in mind that pretty much every program that creates such backup files, also has the option to disable this feature if you want to.

    For example in Gedit, go to Edit->Preferences, and on the Editor-tab uncheck the "Create a backup copy of files before saving"-option.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •