Page 1 of 7 123 ... LastLast
Results 1 to 10 of 68

Thread: Help - Cannot see xp share

  1. #1
    Join Date
    Mar 2011
    Beans
    Hidden!
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Help - Cannot see xp share

    I set up a workgroup in xp, but clicking on it says it's not accessible. I shared one folder.

    Network magic somehow fixed it for xp: I can now see both ubuntu and xp shares.

    I'd like to work on making sure ubuntu is able to see it too (it can see its own share). The problem remains on ubuntu's side. After disabling ufw, I was able to enter windows network to see both computers (prior to that it said "Unable to mount location: Failed to retrieve share list from server"), but now upon clicking on xp, it says the same thing.

    Once I get this fixed, I'd like to reenable ufw, but I need an explanation of the needed allowed rules: is it in or out, and why.

    After I changed
    wins support = no
    to
    wins support = yes
    in smb.conf, it started displaying message "opening ...", but in the end displays the same error.

    But pinging xp hostname works.
    Last edited by l07; December 31st, 2011 at 07:36 AM.

  2. #2
    Join Date
    Jul 2011
    Beans
    3,037
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Help - Cannot see xp share


  3. #3
    Join Date
    Mar 2011
    Beans
    Hidden!
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Help - Cannot see xp share

    I've read all that and it doesn't help.

  4. #4
    Join Date
    Oct 2005
    Location
    Rome, Ga
    Beans
    2,339
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Help - Cannot see xp share

    I'm not reading all those, but I will ask, did you edit /etc/samba/smb.conf to show the linux box workgroup name the same as the windows workgroup?

    That's the main number one problem I have. Updates somehow mess smb.conf up and I have found that I just have to go back and make sure that's correct every time.

  5. #5
    Join Date
    Dec 2009
    Beans
    5,387

    Re: Help - Cannot see xp share

    ** Give this a shot:

    Edit smb.conf as root:
    Code:
    gksu gedit /etc/samba/smb.conf
    Add a line to the [global] section - right under the workgroup line:
    Code:
    name resolve order = bcast host lmhosts wins
    Then restart samba:
    Code:
    sudo service smbd restart
    Code:
    sudo service nmbd restart
    Then wait about 5 minute for the network reset itself.

    ** wins support
    wins support = no
    This is the default setting of Samba.
    wins support = yes
    This has turned your Linux box into a WINS server. Nothing wrong with that if that's what you want to do but you will have to take steps to make that happen. You will need to give that Linux box a static ip address and you will have to modify the network configuration of all the other machines on your network to point to that ip address for name resolution to take place.

    ** ufw

    [1] If you look at the following file all of the rules for Samba have already been provided to you: /etc/ufw/applications.d/samba. Or you can run the following command to get a concise view:
    Code:
    sudo ufw app info Samba
    So to enable Samba through ufw:
    Code:
    sudo ufw allow Samba
    [2] Unfortunately there is an oversight in the basic ufw default setup that needs to be fixed:

    Edit the file as root: /etc/default/ufw

    Look these lines:
    # extra connection tracking modules to load
    IPT_MODULES="nf_conntrack_ftp nf_nat_ftp nf_conntrack_irc nf_nat_irc"

    And make the last line look like this:
    # extra connection tracking modules to load
    IPT_MODULES="nf_conntrack_ftp nf_nat_ftp nf_conntrack_irc nf_nat_irc nf_conntrack_netbios_ns"


    Then restart ufw

  6. #6
    Join Date
    Mar 2011
    Beans
    Hidden!
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Help - Cannot see xp share

    None of it helped. "name resolve order = bcast host lmhosts wins" actually made even xp not work. enabling and disabling wins didn't make any difference (it was initially enabled).

  7. #7
    Join Date
    Mar 2011
    Beans
    Hidden!
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Help - Cannot see xp share

    When the trial of Network magic expired it stopped working on xp, and now I don't see ubuntu's shares.

  8. #8
    Join Date
    Dec 2009
    Beans
    5,387

    Re: Help - Cannot see xp share

    Without any detailed information on how your Linux machine is set up all that anyone can do on this tread is take a WAG.

    Please post the output of the following commands:
    Code:
    hostname
    Code:
    testparm -s
    Code:
    net usershare info --long
    Code:
    smbtree

  9. #9
    Join Date
    Mar 2011
    Beans
    Hidden!
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Help - Cannot see xp share

    Code:
    $ hostname
    n-pc
    $ testparm -s
    Load smb config files from /etc/samba/smb.conf
    rlimit_max: rlimit_max (1024) below minimum Windows limit (16384)
    Processing section "[printers]"
    Processing section "[print$]"
    Loaded services file OK.
    Server role: ROLE_STANDALONE
    [global]
        server string = %h server (Samba, Ubuntu)
        interfaces = 127.0.0.0/8, eth1
        bind interfaces only = Yes
        map to guest = Bad User
        obey pam restrictions = Yes
        pam password change = Yes
        passwd program = /usr/bin/passwd %u
        passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
        unix password sync = Yes
        syslog = 0
        log file = /var/log/samba/log.%m
        max log size = 1000
        dns proxy = No
        usershare allow guests = No
        panic action = /usr/share/samba/panic-action %d
    
    [printers]
        comment = All Printers
        path = /var/spool/samba
        create mask = 0700
        printable = Yes
        browseable = No
    
    [print$]
        comment = Printer Drivers
        path = /var/lib/samba/printers
    $ net usershare info --long
    [files media]
    path=/media/files
    comment=
    usershare_acl=Everyone:R,N-PC\n:F,
    guest_ok=n
    
    [files]
    path=/home/n/Desktop/files
    comment=
    usershare_acl=Everyone:R,N-PC\n:F,
    guest_ok=n
    
    $ smbtree
    cli_start_connection: failed to connect to 192.168.1.36<20> (192.168.1.36). Error NT_STATUS_CONNECTION_REFUSED
    cli_start_connection: failed to connect to N-PC<20> (192.168.1.36). Error NT_STATUS_CONNECTION_REFUSED
    Last edited by l07; January 9th, 2012 at 03:39 PM.

  10. #10
    Join Date
    Dec 2009
    Beans
    5,387

    Re: Help - Cannot see xp share

    Your smb.conf looks factory fresh except for all this stuff:
    interfaces = 127.0.0.0/8, eth1
    bind interfaces only = Yes
    Can you explain the logic on wanting to do this? Is there a eth0 or wlan that you don't want samba to work with? And is eth1 the Ethernet port that you have connected to the router? I would comment out those lines unless there's a reason you have them there.

    Assuming there a good reason for having them there then who or what is 192.168.1.36 ?

    Is that your Linux box? Why not install nmap:
    Code:
    sudo apt-get install nmap
    Run the following command:
    Code:
    sudo nmap -sS -sU -T4 192.168.1.36
    And see if the samba ports are open:
    PORT STATE SERVICE
    139/tcp open netbios-ssn
    445/tcp open microsoft-ds
    137/udp open|filtered netbios-ns
    138/udp open|filtered netbios-dgm

Page 1 of 7 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •