Results 1 to 7 of 7

Thread: Sound Blaster Live! 24 Bit Only plays front OR rear

  1. #1
    Join Date
    Jun 2008
    Beans
    17

    Sound Blaster Live! 24 Bit Only plays front OR rear

    I have been having troubles with my Sound Blaster Live! 24-Bit sound card since I installed Ubuntu. I have a 5.1 Surround sound setup.

    It has only been playing on the Front L + R speakers and the subwoofer.

    Today I entered the Sound Preferences (which i have checked before) and today there were new options. There were 4 options Labeled
    Live! 7.1 24bit [SB0413] CA0106 (ALSA)
    and 3 for OSA

    Some of these options play in the front speakers, some do not work, but one actually plays ONLY in the rear, which has never happened before.

    I am wondering if anyone has had this problem before, or if there is any way to use BOTH sound settings to get it to play in both.

    I do not really know how to edit ALSA other than in this dialogue, but maybe this will be my key to success

  2. #2
    Join Date
    Oct 2010
    Beans
    54
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Sound Blaster Live! 24 Bit Only plays front OR rear

    Have you fixed the problem?

    I have very similar issue in the latest Ubuntu (11.10): http://ubuntuforums.org/showthread.php?t=1860273

    PS This is how it looks:

    Last edited by mr.interested; October 15th, 2011 at 09:02 AM.

  3. #3
    Join Date
    Oct 2010
    Beans
    54
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Sound Blaster Live! 24 Bit Only plays front OR rear

    Does anyone have any suggestions? The sound card was correctly recognized in Ubuntu 10.04, 10.10, and 11.04. I'm surprised that it doesn't work properly in 11.10.

  4. #4
    Join Date
    Jul 2006
    Beans
    1,876
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Sound Blaster Live! 24 Bit Only plays front OR rear

    Code:
    alsamixer
    (in terminal) still works. Have you checked to make sure that what you need is unmuted? To unmute use the left-right keyboard keys and hit m.

  5. #5
    Join Date
    Oct 2010
    Beans
    54
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Sound Blaster Live! 24 Bit Only plays front OR rear

    I've just plugged the card and... magic happened:



    Compare it with the latest one:



    The additional options somehow appeared, but I haven't done anything, just plugged the speakers to the same USB slot after a few days.

    Perhaps some Ubuntu upgrade?

    PS One of the major things that I've changed was "Languages for menus and windows". I've changed English US to other language, and then switched back to English US after restart.
    Last edited by mr.interested; October 18th, 2011 at 10:34 PM.

  6. #6
    Join Date
    Oct 2010
    Beans
    54
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Sound Blaster Live! 24 Bit Only plays front OR rear

    I can now confirm that the problem is with "Languages for menus and windows".

    The card works only with the following order:
    English (UK)
    English (US)
    English

    It doesn't work with:
    English (UK)
    English

    My guess is that the "Languages for menus and windows" isn't available for "English (UK)", and so Ubuntu always skips to the next language. So it looks as the correct settings are available only for "English (US)".

  7. #7
    Join Date
    Oct 2010
    Beans
    54
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Sound Blaster Live! 24 Bit Only plays front OR rear

    Just an update. The problem still occurs whenever I connect the card when system is running, or before I wake it up. In other words, the card is detected properly (ie, with 5.1 settings) only when I connect it before I boot Ubuntu. Otherwise, it doesn't work (I have only 2 speakers active as per the earlier images attached).

    Any ideas what is going on? I didn't have this problem with previous versions of Ubuntu.

    Best

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •