Results 1 to 5 of 5

Thread: Volume is either silent or very loud

  1. #1
    Join Date
    Jun 2006
    Location
    Ontario, Canada
    Beans
    Hidden!
    Distro
    Xubuntu

    Question Volume is either silent or very loud

    In Xubuntu 11.10 (and 11.04) I noticed that my sound is either silent or very loud. In the volume slider, up to 1/4 volume the sound is almost silent, and then after that it jumps to what seems like max volume. It is very annoying because I then have to use the physical dial on my speaks to change the volume, instead of being able to use the keyboard shortcuts.

    Does anyone know how to fix this? I don't seem to get this on my laptop, only my desktop. I have an ASUS M3N78-VM mobo.
    Do you folks like coffee?

  2. #2
    Join Date
    Jun 2006
    Location
    Ontario, Canada
    Beans
    Hidden!
    Distro
    Xubuntu

    Re: Volume is either silent or very loud

    bump.
    Do you folks like coffee?

  3. #3
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Volume is either silent or very loud

    Hello neighbour.

    Have a look at this link for a potential solution: http://askubuntu.com/questions/15069...e-mixer-levels.

  4. #4
    Join Date
    Jun 2006
    Location
    Ontario, Canada
    Beans
    Hidden!
    Distro
    Xubuntu

    Re: Volume is either silent or very loud

    Thanks for the information Toz, that does appear to be the same issue I am having. I will try the workaround/fix tonight.
    Do you folks like coffee?

  5. #5
    Join Date
    Jun 2006
    Location
    Ontario, Canada
    Beans
    Hidden!
    Distro
    Xubuntu

    Re: Volume is either silent or very loud

    TOZ, that link provided a partial solution that will works fine for now. Thanks!

    I set the following in ~/.pulse/default.pa
    Code:
    load-module module-udev-detect ignore_dB=1
    load-module module-alsa-sink control=PCM
    So this made it so that the PCM channel is adjusted instead of the master, which works far better. This works when adjusting the slider on the panel, but if I use the keyboard shortcuts it still adjusts the master. I worked around this by adding the keyboard short cuts to Super+UP/DOWN:
    Code:
    amixer set PCM 10+
    amixer set PCM 10-
    I tried setting the keyboard shortcuts to the media volume buttons on my keyboard, but it didn't work. Oh well, this gets me close enough to what I need.

    I think the root cause is that the sound card driver is not reporting to palseaudio correctly. I will look to open a bug for this.
    Do you folks like coffee?

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •