Results 1 to 9 of 9

Thread: Banshee 2.2 and amazon

  1. #1
    Join Date
    Apr 2011
    Beans
    67
    Distro
    Ubuntu Studio 13.04 Raring Ringtail

    Banshee 2.2 and amazon

    Ok, I just upgraded from ubuntu 11.4 to 11.10, and one thing really ticks me off. While banshee 2.0 (included with 11.4) could download the .amz files from the amazon cloud player, it seems that banshee 2.2 (included with 11.10) cannot. Whenever I try I get something to the effect of "The amazon downloader file is not valid"

    If anyone has a solution please help me out.

  2. #2
    Join Date
    Apr 2011
    Beans
    67
    Distro
    Ubuntu Studio 13.04 Raring Ringtail

    Re: Banshee 2.2 and amazon

    hmm, forgive me, it seems that i cannot download the fire because I'm running a 64 bit system and amazon thinks it should give me 64 bit .amz files. anyone know a way around this?

  3. #3
    Join Date
    Apr 2011
    Beans
    67
    Distro
    Ubuntu Studio 13.04 Raring Ringtail

    Re: Banshee 2.2 and amazon

    then again, I tried it on a 32 bit system with the same result... hmm...

  4. #4
    Join Date
    Nov 2005
    Location
    Jackson, TN USA
    Beans
    463
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Banshee 2.2 and amazon

    Having a similar problem. I downloaded the .deb file from the Amazon site and can't satisfy the dependencies to install it.

    So how do I get Banshee to download my music from Amazon like it used to?
    "Despite millions of dollars of research, Death continues to be Americas number one killer."

    Kingdom Computer Solutions

  5. #5
    Join Date
    Apr 2011
    Beans
    67
    Distro
    Ubuntu Studio 13.04 Raring Ringtail

    Re: Banshee 2.2 and amazon

    clamz is also giving me a weird error message. The .amz files from the cloud player are slightly different from the regular ones. I would say this has something to do with the OS but I tried it on a linux mint 11 (which is more similar to ubuntu 11.04 that 11.10) and got the same result.

    The error from clamz is

    Code:
    ERROR: Invalid base64 data in AMZ file 'Amazon-MP3-1318990736.amz'
    
    0 of 1 AMZ files downloaded successfully.

  6. #6
    Join Date
    Apr 2011
    Beans
    67
    Distro
    Ubuntu Studio 13.04 Raring Ringtail

    Re: Banshee 2.2 and amazon

    I have a temporary fix untill this can be rectified. Install the windows version of the amazon mp3 downloader with wine. Then open the .amz file with it. It will give you an error and crash when it tries to add the songs to the Windows Media Player but it will download the music.

    Cheers

  7. #7
    Join Date
    Sep 2009
    Location
    San Jose, CA
    Beans
    37
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Banshee 2.2 and amazon

    I'm having the same issue. When I try to download something from the Amazon Cloud Player after making a purchase, it's asking me to install the Amazon MP3 downloader (same on either 32 or 64 bit). I don't recall ever seeing this on 11.04. Seems like pretty basic functionality. Anyone else seeing this or have a solution that doesn't invalid installing the windows version?

  8. #8
    Join Date
    Jul 2011
    Beans
    1

    Re: Banshee 2.2 and amazon

    I am having the same issue since I upgraded to Ubuntu 11.10.

  9. #9
    Join Date
    Sep 2009
    Location
    San Jose, CA
    Beans
    37
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Banshee 2.2 and amazon

    It turns out that this was due to the following bug.

    https://bugzilla.gnome.org/show_bug.cgi?id=661467

    I went ahead and added the Banshee daily ppa, ppa:banshee-team/banshee-daily and ran updates to get the fix.

    It now works fine again.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •