In Kubuntu 11.10, my default mail and browser applications are Thunderbird and Firefox respectively.

After installing Google Chrome (primarily for its integrated PDF viewing capabilities) I found that Thunderbird was suddenly opening http/https links in Google Chrome rather than Firefox.

After double checking that Google Chrome was not my default browser and that Firefox was my default browser, I still experienced the same behaviour.

After a search, I found this link that explained what happened in a Fedora setup:

http://www.geeklab.info/2011/05/love...m-thunderbird/

I did what was advised there:

1. sudo edit /usr/share/applications/defaults.list

2. Change

Code:
[Default Applications]
text/html=google-chrome.desktop
text/xml=google-chrome.desktop
application/xhtml_xml=google-chrome.desktop
x-scheme-handler/http=google-chrome.desktop
x-scheme-handler/https=google-chrome.desktop
x-scheme-handler/ftp=google-chrome.desktop
to

3.
Code:
[Default Applications]
text/html=firefox.desktop
text/xml=firefox.desktop
application/xhtml_xml=firefox.desktop
x-scheme-handler/http=firefox.desktop
x-scheme-handler/https=firefox.desktop
x-scheme-handler/ftp=firefox.desktop
Note that in Kubuntu it is firefox rather than mozilla-firefox that is the replacement string.

I do not know how this default setting happened in Kubuntu as gvfs-open is not installed. Anyway, the default was set in a sneaky fashion on my system without my explicit intervention, and I am grateful that David at GeekLab found out what had happened and how to fix it.

I hope this helps others.