I have an iBook G4. The trackpad used to work in earlier versions of Ubuntu, but I just finished upgrading and it no longer works in Ubuntu 11.10.

alex@orientalibombus:~$ sudo trackpad show
no trackpad !

I checked /var/log/Xorg.0.log and searched for ADB mouse and this seemed to be the relevant part:

[ 46.323] (II) config/udev: Adding input device ADB mouse (/dev/input/event2)
[ 46.323] (**) ADB mouse: Applying InputClass "evdev pointer catchall"
[ 46.323] (II) Using input driver 'evdev' for 'ADB mouse'
[ 46.323] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[ 46.323] (**) ADB mouse: always reports core events
[ 46.323] (**) ADB mouse: Device: "/dev/input/event2"
[ 46.323] (--) ADB mouse: Found 3 mouse buttons
[ 46.323] (--) ADB mouse: Found relative axes
[ 46.323] (--) ADB mouse: Found x and y relative axes
[ 46.323] (II) ADB mouse: Configuring as mouse
[ 46.323] (**) ADB mouse: YAxisMapping: buttons 4 and 5
[ 46.328] (**) ADB mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[ 46.328] (**) Option "config_info" "udev:/sys/devices/virtual/input/input2/event2"
[ 46.328] (II) XINPUT: Adding extended input device "ADB mouse" (type: MOUSE)
[ 46.328] (II) ADB mouse: initialized for relative axes.
[ 46.328] (**) ADB mouse: (accel) keeping acceleration scheme 1
[ 46.328] (**) ADB mouse: (accel) acceleration profile 0
[ 46.328] (**) ADB mouse: (accel) acceleration factor: 2.000
[ 46.328] (**) ADB mouse: (accel) acceleration threshold: 4
[ 46.338] (II) config/udev: Adding input device ADB mouse (/dev/input/mouse0)
[ 46.338] (II) No input driver/identifier specified (ignoring)

There are sections regarding my Logitech mouse, the ADB keyboard, powerbutton, etc. Can you spot anything suspicious?