Page 1 of 3 123 LastLast
Results 1 to 10 of 25

Thread: Wireless / WiFi stopped working after Ubuntu 11.10 upgrade

  1. #1
    Join Date
    Jan 2011
    Beans
    16

    Wireless / WiFi stopped working after Ubuntu 11.10 upgrade

    I hope this helps someone out there, here's my story and how I fixed it.

    After I upgrade from 11.04 to 11.10 my WiFi went out during installation and never came back on, even after the install completed. My netbook is a Sony VAIO VPCM111AX, I was familiar with the the ralink wireless issues so I had many rt2 and rt3 wireless drivers blacklisted. So I went back and unblacklisted these drivers.

    Code:
    sudo gedit /etc/modprobe.d/blacklist.conf
    # These don't function with WiFi when netbook is unplugged
    blacklist rt3390sta
    blacklist rt2x00lib
    blacklist rt2800pci
    blacklist rt2x00usb
    blacklist rt2x00pci
    This didn't solve the problem. I went back to find my specific driver by this:

    Code:
    lspci | grep work
    and I found that my driver was RT3090

    01:00.0 Network controller: Ralink corp. RT3090 Wireless 802.11n 1T/1R PCIe
    Upon some investigation I found that 11.10 doesn't support some wireless drivers.
    Before proceeding I wanted to check a few more things such as

    Code:
    sudo lshw -C network
    *-network
    description: Wireless interface
    product: RT3090 Wireless 802.11n 1T/1R PCIe
    vendor: Ralink corp.
    physical id: 0
    bus info: pci@0000:01:00.0
    logical name: ra0
    version: 00
    serial: 0c:ee:e6:ff:17:dd
    width: 32 bits
    clock: 33MHz
    capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
    configuration: broadcast=yes driver=RALINK WLAN driverversion=2.3.1.3 ip=192.168.2.10 latency=0 multicast=yes wireless=Ralink STA
    resources: irq:16 memory:fe900000-fe90ffff
    *-network
    description: Ethernet interface
    product: JMC260 PCI Express Fast Ethernet Controller
    vendor: JMicron Technology Corp.
    physical id: 0.5
    bus info: pci@0000:02:00.5
    logical name: eth0
    version: 02
    serial: 00:24:be:c4:d4:85
    size: 10Mbit/s
    capacity: 100Mbit/s
    width: 32 bits
    clock: 33MHz
    capabilities: pm pciexpress msix msi bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
    configuration: autonegotiation=on broadcast=yes driver=jme driverversion=1.0.8 duplex=half latency=0 link=no multicast=yes port=MII speed=10Mbit/s
    resources: irq:42 memory:fe800000-fe803fff ioport:e100(size=128) ioport:e000(size=256)
    Then:

    Code:
    lsmod
    Module Size Used by
    nls_iso8859_1 12617 1
    nls_cp437 12751 1
    vfat 17308 1
    fat 55577 1 vfat
    mmc_block 22393 1
    bnep 17923 2
    rfcomm 38408 8
    parport_pc 32114 0
    ppdev 12849 0
    binfmt_misc 17292 1
    btusb 18160 2
    uvcvideo 67271 0
    videodev 85626 1 uvcvideo
    snd_hda_codec_realtek 254125 1
    bluetooth 148839 23 bnep,rfcomm,btusb
    snd_hda_intel 24262 2
    snd_hda_codec 91754 2 snd_hda_codec_realtek,snd_hda_intel
    snd_hwdep 13276 1 snd_hda_codec
    snd_pcm 80468 2 snd_hda_intel,snd_hda_codec
    snd_seq_midi 13132 0
    snd_rawmidi 25241 1 snd_seq_midi
    snd_seq_midi_event 14475 1 snd_seq_midi
    joydev 17393 0
    snd_seq 51567 2 snd_seq_midi,snd_seq_midi_event
    snd_timer 28932 2 snd_pcm,snd_seq
    snd_seq_device 14172 3 snd_seq_midi,snd_rawmidi,snd_seq
    snd 55902 13 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec, snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,sn d_seq_device
    i915 505108 3
    soundcore 12600 1 snd
    snd_page_alloc 14115 2 snd_hda_intel,snd_pcm
    psmouse 73673 0
    serio_raw 12990 0
    rt3090sta 794403 1
    drm_kms_helper 32889 1 i915
    sony_laptop 39681 0
    drm 192226 4 i915,drm_kms_helper
    jmb38x_ms 17406 0
    memstick 15857 1 jmb38x_ms
    i2c_algo_bit 13199 1 i915
    video 18908 1 i915
    lp 17455 0
    parport 40930 3 parport_pc,ppdev,lp
    jme 40330 0
    sdhci_pci 13658 0
    sdhci 27360 1 sdhci_pci
    Lastly I checked this:

    Code:
    rfkill list all
    0: sony-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: no
    1: sony-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
    2: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
    If the "no"'s here are yes's for you run this:

    Code:
    rfkill unblock all
    After all this I found an old version of the rt3090 driver here:

    https://launchpad.net/~markus-tisoft...0~ppa1_all.deb

    I installed the driver and restarted the computer and all is well. I haven't had to reblacklist the other ralink drivers, everything seems to be working well.

    I hope this helps someone because this problem drove me mad.

    Just for reference: I did find that some computers needed to blacklist certain drivers depending on computer models:

    blacklist bcm43xx
    blacklist acer_wmi
    There are a lot of other drivers that need to be blacklisted depending on the type of computer you have and others need to install older versions of the wireless driver (as I did) to allow this to work.

  2. #2
    Join Date
    Nov 2010
    Beans
    4

    Re: Wireless / WiFi stopped working after Ubuntu 11.10 upgrade

    Thank you!

    It worked as you said on my HP ProBook 4720s.

    - I removed the blacklist rt2800pci (I had blacklisted this one when I upgraded to 11.04). This restored the ability to activate the wireless network using the wireless button. But I still couldn't connect to any Access Point.

    - I installed the old driver using the link you provided.

    - and I blacklisted bcm43xx and acer_wmi just in case.

    Thanks again
    Last edited by dfv78; October 15th, 2011 at 10:44 PM.

  3. #3
    Join Date
    May 2005
    Beans
    35

    Re: Wireless / WiFi stopped working after Ubuntu 11.10 upgrade

    Thanks OP. This definitely helped me. On my averatec N1200, it first gave me a warning that the "driver does not meet ubuntu standards" which I ignored. After reboot, it "forgot" my wpa-2 password. I had to retype it. Everything works now.

    If anyone is looking for instructions.... all it needs it download and install deb file linked by OP using the software center. The install can take a while because it is DKMS, be patient.

  4. #4
    Join Date
    Jul 2008
    Location
    RI
    Beans
    51
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Wireless / WiFi stopped working after Ubuntu 11.10 upgrade

    life saver!!! been messing with this for days

  5. #5
    Join Date
    Jun 2008
    Beans
    79

    Re: Wireless / WiFi stopped working after Ubuntu 11.10 upgrade

    Thank you very much for this information. About to go try it out.

  6. #6
    Join Date
    Oct 2011
    Beans
    1

    Smile Re: Wireless / WiFi stopped working after Ubuntu 11.10 upgrade

    I'm another satisfied customer; thanks!

    on the downside...

    I was rather worried at having to scorn two security warning in order to install the good old driver. This might encourage me to adopt such pig-headed behaviour at less appropriate times.

    My confidence as a self-styled "Ubuntu evangelist" takes a knock when I hit this sort of problem.

  7. #7
    Join Date
    Oct 2008
    Beans
    13
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Wireless / WiFi stopped working after Ubuntu 11.10 upgrade

    Worked for me, I just had to add a line to the /etc/modules

    rt3090sta

    and after a reboot. Everything worked ok.

  8. #8
    Join Date
    Oct 2011
    Beans
    1

    Re: Wireless / WiFi stopped working after Ubuntu 11.10 upgrade

    Thank you guys, especially to cirelosborn
    It works very well.
    I should see this thread when i just upgrade to 11.10 soon !

  9. #9
    Join Date
    Apr 2007
    Location
    Århus, Denmark
    Beans
    233
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: Wireless / WiFi stopped working after Ubuntu 11.10 upgrade

    Hi, I have a Lenovo s205, and have been struggling really hard to get wireless working right.
    I can get it to works in several different ways, but the network speed is very low.
    Now I have downloaded the package "rt3090-dkms_2.4.0.4-0ubuntu0~ppa0_all.deb" from Markus Heberling, and installed it using software center.
    It did not work, so I blacklisted "acer_wmi", and now it does. -But again at a terrible low speed. (below 80Kb/sec.)
    How do I find out what drivers should be blacklisted, and what driver is actually being used?

  10. #10
    Join Date
    Apr 2007
    Location
    Århus, Denmark
    Beans
    233
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: Wireless / WiFi stopped working after Ubuntu 11.10 upgrade

    I've been fighting this for 3 weeks straight, but now it finally works.
    cirelosborn you are a true hero!

    What it took was to install version 2.3.1.3 (I had installed 2.4.0.4)
    Blacklist acer_wmi in /etc/modprobe.d/blacklist.conf
    And add rt3090sta to /etc/modules

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •