Results 1 to 3 of 3

Thread: Help needed in upgrading synaptics touchpad driver in 10.04

  1. #1
    Join Date
    Jul 2011
    Location
    UK
    Beans
    52
    Distro
    Xubuntu 12.04 Precise Pangolin

    Red face Help needed in upgrading synaptics touchpad driver in 10.04

    I tried (once) to upgrade the synaptics touchpad driver on 10.04

    I need it upgrading from 1.2.1-1ubuntu4 (version on 10.04) to 1.3.99 (version on 11.04)

    This is to get around a major problem with the touchpad with the earlier driver. If I could run 11.04 I would but I can't because of another ongoing issue (cursor locking up after a few days use when the rest of the system is fine re: thread: http://ubuntuforums.org/showthread.p...6#post11273636 )

    I suspect that upgrading the synaptics touchpad driver is not straightforward. Automatically I got a dependency error .. It was asking for different C++ headers I recall. The later touchpad driver I would not even be sure will work with 10.04.

    If I can get it installed it will resolve two issues for me and also get me safely onto 10.04 (long term support).

    I could go back to 10.04 if anyone wants me to get the exact dependency which the new driver was requesting but I am working on getting 11.04 stable currently (by upgrading the kernel) -- further feedback on what I'm trying to sort out in this thread:

    http://ubuntuforums.org/showthread.php?t=1849085

    What I really need to know from an expert is how straightforward it will be to upgrade the synaptics driver on 10.04 to the latest one. I have googled for this but can't see anyone/any reference to it having been done.

    The synaptics drivers I got from here:

    https://launchpad.net/ubuntu/natty/+...nput-synaptics

    I was installing (when I tried) from the .deb file:

    xserver-xorg-input-synaptics_1.3.99+git20110116.0e27ce3a-0ubuntu12.1_amd64.deb

    here are the version numbers between 10.04 and 11.04

    SYNAPTICS INSTALLLED 1.2.2-1ubuntu4 (10.04)
    latest (11.04) = 1.3.99
    Last edited by aspidistra; September 24th, 2011 at 07:01 PM.

  2. #2
    Join Date
    Jul 2011
    Location
    UK
    Beans
    52
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: Help needed in upgrading synaptics touchpad driver in 10.04

    bump

  3. #3
    Join Date
    Jul 2011
    Location
    UK
    Beans
    52
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: Help needed in upgrading synaptics touchpad driver in 10.04

    bump

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •