Page 1 of 12 12311 ... LastLast
Results 1 to 10 of 119

Thread: Unity panel always displayed on top of fullscreen windows

  1. #1
    Join Date
    Nov 2008
    Location
    Oita, Japan
    Beans
    419
    Distro
    Ubuntu

    Unity panel always displayed on top of fullscreen windows

    Annoyingly, when any kind of application is in full-screen, the text and icons on the panel are always visible (appmenu, indicators, the clock etc).

    Even more annoyingly, the mouse regards them as under the full-screen window (where they should be), so the indicator icons and application menus don't respond to clicks.

    Is there any way to stop the panel from being displayed on top of everything?

    I don't want to hide the panel, just have it properly covered when a full-screen window opens.

    Is there any setting for this in ccsm, gconf, or dconf?

  2. #2
    Join Date
    Nov 2009
    Beans
    117
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Unity panel always displayed on top of fullscreen windows

    What apps are you using that doesn't hide the panel? I haven't found any app with that behaviour, all my apps hides the panel when in fullscreen.

  3. #3
    Join Date
    Nov 2010
    Location
    India
    Beans
    4,827
    Distro
    Ubuntu Development Release

    Re: Unity panel always displayed on top of fullscreen windows

    Hey i have seen issue like you got. some times this type of issues needs capture of problem . so please attach a screen shot and by the way follow this

    http://ubuntuforums.org/showthread.php?t=1654141

    All the best
    Raja

    రాజ శేఖర్ రెడ్డి

  4. #4
    Join Date
    Nov 2008
    Location
    Oita, Japan
    Beans
    419
    Distro
    Ubuntu

    Re: Unity panel always displayed on top of fullscreen windows

    Quote Originally Posted by scarleo View Post
    What apps are you using that doesn't hide the panel?
    It is not a problem with the applications.

    The panel is displayed on top of every full-screen application of every kind.

    Please understand that I do not mean the launcher on the left side.

    I am talking about the panel across the top of the screen.


    Quote Originally Posted by raja.genupula View Post
    ...and by the way follow this...
    Thank you for the link, unfortunately this is not my problem. My problem has to do with full-screen applications.

    I'm attaching two screenshots.

    fullscreen.panel.1.png = a video in Totem.
    fullscreen.panel.2.png = a game in wine.
    Attached Images Attached Images

  5. #5
    Join Date
    Dec 2011
    Beans
    1

    Re: Unity panel always displayed on top of fullscreen windows

    I'm also having this problem.

    I am using Citrix Receiver to remote access another machine, and it tries to use the full screen but the Unity panel still appears at the top. I guess it's as a result of this that I still have a scrollbar on the RHS and the mouse is mis-placing all of my clicks within the screen.

    I should mention I'm using a fresh install of 11.10.

    Full screen is working fine with Firefox when I hit F11. With the citrix client F11 is just going through to the remote session though.
    Attached Images Attached Images
    Last edited by fwsober; December 3rd, 2011 at 07:18 PM.

  6. #6
    Join Date
    Mar 2007
    Location
    London, England
    Beans
    18
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: Unity panel always displayed on top of fullscreen windows

    My solution was:

    If you have Compiz enabled (as in Unity by default):

    Code:
    sudo apt-get install compizconfig-settings-manager
    Then, in Control Center: Personal / CompizConfig Settings Manager
    check Utility / Workarounds / Legacy Fullscreen Support.

  7. #7
    Join Date
    Nov 2008
    Location
    Oita, Japan
    Beans
    419
    Distro
    Ubuntu

    Re: Unity panel always displayed on top of fullscreen windows

    Quote Originally Posted by redeemer
    Then, in Control Center: Personal / CompizConfig Settings Manager
    check Utility / Workarounds / Legacy Fullscreen Support.
    This is not a solution to my problem.

    The problem is not how windows are rendered in full-screen.

    Unity's panel is ALWAYS visible under ALL circumstances and with ANY settings.

    Furthermore, when an application is in full-screen, the panel cannot be clicked. It is visible, but not usable.

    I theorize that X11 correctly layers input so the full-screen window is "on top" and receives clicks, but something forces the panel to be displayed on top.

    In Gnome 2 panels could be configured to "auto-hide" and scroll off the screen until moused over.

    The Unity launcher (left edge) can be configured this way.

    The Unity panel (top edge) cannot.

    There are no settings, no functions, no features at all to hide this panel.

    One of the design goals of Unity was to open more screen real-estate for users.
    The panel is definitely detracting from that.

    I'm surprised that no one else has posted about this.
    It isn't just me.
    Everyone using Unity should be experiencing this.
    Maybe I'm the only one bothered by it?

  8. #8
    Join Date
    Feb 2012
    Beans
    18

    Re: Unity panel always displayed on top of fullscreen windows

    THeres no settings anywhere in unity. No right click -> hide on icons, no drag to move... I dont get it. I can't find the settings for anything.

    But i'm sure it will be ironed out..

    Your issue sounds pretty drastic and I would suggest unique. I doubt the release would have gone out with a ghost panel stuck over the top of full windows. If I am understanding correctly.

  9. #9
    Join Date
    Jun 2010
    Location
    London, England
    Beans
    6,774
    Distro
    Ubuntu Development Release

    Re: Unity panel always displayed on top of fullscreen windows

    In full screen mode the windows are moving under the panel. That is what is happening and it should not happen.

    There is no intention to make the top panel disappear when a window is maximised. Remember, it is the intention with unity for the top panel to be the place for the max, min & close buttons of a window as well as for app indicators.

    I am using 12.04 development release and maximised windows stay below the top panel but up against it.

    we have the ability to bounce a window against the top panel and when we let go of the mouse button the window maximizes. Then when we move the mouse over the top panel the pointer should change to a hand icon so that we can grab the top of the maximized window and pull it down at which point the window snaps back to its original size. My point is that the maximized window should not be under the top panel. That is the problem and not the one of the top panel not disappearing.

    I do not know how you stop this from happening but my guess is that it is to do with a setting in CCSM. I cannot check this out as I am not using 11.10 but 12.04 and there are changes to CCSM in 12.04.

    Regards.

    P.S. It occurs to me that your thread title is a little misleading. This is not a problem with maximized windows. Is it? It is a problem with playing video in full screen mode. Is it not?
    Last edited by grahammechanical; February 12th, 2012 at 06:06 PM.
    It is a machine. It is more stupid than we are. It will not stop us from doing stupid things.
    Ubuntu user #33,200. Linux user #530,530


  10. #10
    Join Date
    Feb 2010
    Location
    Nr BrandsHatch, S'oaks UK
    Beans
    1,241
    Distro
    Lubuntu 13.04 Raring Ringtail

    Re: Unity panel always displayed on top of fullscreen windows

    Hi! quequotion,
    You posted:
    I'm surprised that no one else has posted about this.
    It isn't just me.
    Everyone using Unity should be experiencing this.
    Maybe I'm the only one bothered by it?
    Not so! I am running 11.10 and full screen Firefox Window extends to, but not over or under, the top Bar. Exactly as grahammechanical describes for 12.04

    Other apps, including for instance LibreOffice and gedit, when clicked to to full screen extend to literally full screen, so they appear to be 'under' the title bar.

    However, when the Mouse cursor is on the top bar the Window title moves to the right, or the Global menu starts after the buttons, revealing the three control buttons, and they are effective.

    However, contrary to what you describe, the Icons on the right all work normally.

    The Mouse cursor changes to a hand but you cannot drag a fullscreen window anyway, you have to reduce it with the size button first.
    grahammechanical, Posted :
    P.S. It occurs to me that your thread title is a little misleading. This is not a problem with maximized windows. Is it? It is a problem with playing video in full screen mode. Is it not?
    On the evidence of the above the answer is No! - unless I unknowingly have the same fault that quequotion has.

    What you, { QQ } describe, appears to be the failure to detect the mouse cursor is on the top bar.

    Edit: I have just logged out & in to check that both Unity and Gnome Classic in 11.10 behave the same way. It is limited to an Ubuntu log-in, in Gnome Classic, it does not occur and grahammechanical's description applies.

    Chao!, bogan.
    Last edited by bogan; February 12th, 2012 at 06:45 PM. Reason: Gnome Classic note added.Names swap.
    "Better Solutions may bring Worsened Problems": After Lao Tse, b. circa 405BC. a contemporary of Confucius, who died circa 600BC.
    They did things differently in those days, apparently!!

Page 1 of 12 12311 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •