Is "/usr/bin/which" installed at your system?
Yes, it is.

I assume you have an empty value in "Options - Setting - Sudo frontend". Was this intended or did it happen on its own? Since when do you have this setting? Setting a valid one (e.g. /usr/bin/kdesudo or /usr/bin/gksu) in there will probably remove the error messages.
That option is set to /usr/bin/kdesudo

Do you use Gnome or KDE? Or are there any other specific things to your system?
I use KDE, I'm not using any weird settings or anything, just default.