Results 1 to 3 of 3

Thread: Problem with microphone, Toshiba A660 laptop

  1. #1
    Join Date
    Jan 2011
    Beans
    19

    Problem with microphone, Toshiba A660 laptop

    Hi,

    I have a Toshiba Satellite A660 laptop with Ubuntu 10.04.
    I am sure that the internal microphone works because when I reboot into Windows it works fine. It does not work in Ubuntu instead.
    I tried three things that were suggested in other threads of this forum.

    1) Action: I checked all the volumes, made sure that the microphone is not muted and selected the proper device as "Analog Stereo Duplex".
    Result: no improvements.

    2) Action: I installed PulseAudio to better manage the volumes.
    Result: no improvements.

    3) Action: in the Terminal, I executed the line "
    sudo gedit /etc/modprobe.d/alsa-base.conf " and then added the line " options snd-hda-intel model=toshiba " at the bottom of the page that opened. I saved, closed and rebooted.
    Result: no improvements.

    Now, as I know it is useful in order to receive help, I executed in the Terminal the command "
    wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh && bash alsa-info.sh " .
    The link to where data were uploaded is "
    http://www.alsa-project.org/db/?f=f2...07c92c74497eeb " .

    Please, does anybody have any other suggestion about what to do?

    Thank you.
    Last edited by marcogh79; August 23rd, 2011 at 07:47 AM.

  2. #2
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,883
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Problem with microphone, Toshiba A660 laptop

    Quote Originally Posted by marcogh79 View Post
    Hi,

    I have a Toshiba Satellite A660 laptop with Ubuntu 10.04.
    I am sure that the internal microphone works because when I reboot into Windows it works fine. It does not work in Ubuntu instead.
    I tried three things that were suggested in other threads of this forum.

    1) Action: I checked all the volumes, made sure that the microphone is not muted and selected the proper device as "Analog Stereo Duplex".
    Result: no improvements.

    2) Action: I installed PulseAudio to better manage the volumes.
    Result: no improvements.

    3) Action: in the Terminal, I executed the line "
    sudo gedit /etc/modprobe.d/alsa-base.conf " and then added the line " options snd-hda-intel model=toshiba " at the bottom of the page that opened. I saved, closed and rebooted.
    Result: no improvements.

    Now, as I know it is useful in order to receive help, I executed in the Terminal the command "
    wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh && bash alsa-info.sh " .
    The link to where data were uploaded is "
    http://www.alsa-project.org/db/?f=f2...07c92c74497eeb " .

    Please, does anybody have any other suggestion about what to do?

    Thank you.
    Is that analog or digital mic? You should change the auto model to:
    Code:
    laptop-amic
    or
    laptop-dmic

  3. #3
    Join Date
    Jan 2011
    Beans
    19

    Re: Problem with microphone, Toshiba A660 laptop

    Hi Lidex,

    I tried the codes you suggested me, but I could not made it work.

    I solved the problem passing to Ubuntu 11.04 . Now everything seems to work fine, even the wireless networks that had disappeared with the 10.04.

    Thanks.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •