Added both the lines
# Last Modified: Sat Jul 30 23:26:18 2011
#include <tunables/global>

/home/tux/.firefox/firefox {
  #include <abstractions/base>
  #include <abstractions/fonts>
  #include <abstractions/gnome>
  #include <abstractions/kde>
  #include <abstractions/nameservice>

  /bin/dash ix,
  /bin/uname rix,
  /etc/fstab r,
  @{PROC}/ r,
  @{HOME}/ r,
  @{HOME}/.config/** rw,
  @{HOME}/.kde/** r,
  @{HOME}/.mozilla/firefox/** rwk,
  @{HOME}/Downloads/** rw,
  /home/tux/.firefox/** mrwixkl,
  @{HOME}/.mozilla/** rwk,
  @{HOME}/.mozilla/plugins/** rwk,

  @{PROC}/** r,

  /usr/bin/basename rix,
  /usr/bin/dirname rix,
  /usr/bin/expr rix,
  /usr/share/** r,

  /usr/lib/mozilla/plugins/** rmixk,

# Flash
  owner @{HOME}/.adobe/ rw,
  owner @{HOME}/.adobe/** rw,
  owner @{HOME}/.macromedia/ rw,
  owner @{HOME}/.macromedia/** rw,

# Allow flash to use video acceleration
  /dev/nvidiactl rw, 
  /dev/nvidia0 rw,

Now while trying play a video at youtube log says

Aug  2 07:47:07 tux kernel: [ 1188.398593] type=1503 audit(1312251427.386:1190):  operation="ptrace" pid=2312 parent=1 profile="/home/tux/.firefox/firefox" tracer=2312 tracee=1468

I actually tried adding

@{HOME}/.mozilla/plugins/** rw
but didnt include "k". I read k means lock. I will definitely learn about in details. Then I got the /PROC.

I am getting there .

But I dont know what to do about ptrace. Just guessing, need to add executable permission to @{PROC}/ r ??.

I dont wanna experiment too much with this profile or I will mess it up. Once this gets solved I will start with something easy. Please suggest something other than Privoxy. I don't wanna write a profile for app which I don't use. But if you ask I will start with privoxy virtually.