Results 1 to 4 of 4

Thread: Apple Magic Trackpad issue

  1. #1
    Join Date
    Nov 2008
    Location
    Wallington
    Beans
    10
    Distro
    Ubuntu 11.04 Natty Narwhal

    Question Apple Magic Trackpad issue

    Hi,

    I have a apple magic trackpad which worked until the recent Kernel update. The trackpad is listed as connected under the Bluetooth configuration.

    Threat:
    The mouse cursor doesn't react to any of my movements.

    Little bit regarding my system.
    I use Ubuntu 11.04 with a gnome-shell and KDE-environment.
    The Bluetooth dongle seams to working fine.
    I am able connect my bluetooth Keyboard and mobile phone. I keyboard input is without any problems.

    Troubleshooting approach till now:
    1.I tried to unpair the Trackpad and repair it, which seams to be working fine.
    I tried also to unpair it, restart ubuntu an than pair it agin.
    2.I replaced the batteries.


    Well I am open to any suggestions

  2. #2

    Re: Apple Magic Trackpad issue

    Moved to Apple forum.
    Learning is not attained by chance, it must be sought for with ardor and attended to with diligence. Abigail Adams ( 1744 - 1818 ), 1780;

    My blog Poetry and More Free Ubuntu Magazine

  3. #3
    Join Date
    May 2011
    Beans
    39

    Re: Apple Magic Trackpad issue

    Same issue here. Tried multiple machines and kernel compilations. To get any movement, it seems you need the module 'hid-magicmouse'. However, it seems to be the final filter any settings in xorg.conf. The module's alias links to the trackpad's pci location and it applies the module's parameters. It made my trackpad into a giant button, with no movement, and only the press-click with one finger working. Although, if you're fine without tap-clicks, if you leave all settings out of xorg.conf, the trackpad has the synaptics driver's gesture configuration and movement does work.

  4. #4
    Join Date
    Nov 2008
    Location
    Wallington
    Beans
    10
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Apple Magic Trackpad issue

    well i tried to remove all the bits in Xorg. it still did not work.
    I don't know how to check.. the system inorder to make sure that everything is back to normal.

    I removed my entries in /etc/X11/xorg and also in usr/share/X11/ thats all i guess..

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •