Good news: Instead of using a USB boot media, I created a DVD (Ubuntu-11.04-desktop-amd64.iso) which allowed me to select the "nomodeset" option. Installation is currently in progress but it looks like everything works out fine.

Thank you!