Results 1 to 3 of 3

Thread: HDMI audio not working on 1015pn

  1. #1
    Join Date
    Jul 2011
    Beans
    18

    HDMI audio not working on 1015pn

    I'm running Ubuntu 11.04 on Asus Eee PC 1015pn, which I have configured to multi-boot.

    The HDMI audio works on my XBMC Live partition... but I cannot find a solution to get the HDMI audio to work on my Ubuntu partition.

    This is the "solution" for my exact model taken from this page:

    Get and install the latest nvidia binary drivers from the x-swat ppa https://launchpad.net/~ubuntu-x-swat/+archive/x-updates

    open a terminal and type "aplay -l"

    you will get a list of Playback devices containing the analog HDA Intel on card0 and a number of NVidia HDMI devices on card1. Test with aplay which of the devices is the good one in your case (here it's device 8 on card 1)

    now add your hw device string to pulseaudio
    "sudo gedit /etc/pulse/default.pa"

    load-module module-alsa-sink device=hw:1,8
    Restart pulseaudio or reboot your system. Now open the sound Preferences, Hardware Tab and check that the "HDMI Output" profile is enabled.
    I opened the alsamixer and nothing is muted, so I thought that maybe the problem is that Intel is listed as the default soundcard, opposed to Nvidia.

    Every guide to change the default soundcard did not work. They all involved the following commands/configs which do not exist on my system:

    -"sudo asoundconf" returns command not found

    -"/etc/modprobe.d/" does not exist, so there is no config to edit.



    Thanks in advance!

  2. #2
    Join Date
    Feb 2009
    Location
    Dallas, TX
    Beans
    6,697
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: HDMI audio not working on 1015pn

    Have you take a look or tried this?

    Regards.

  3. #3
    Join Date
    Jul 2011
    Beans
    18

    Re: HDMI audio not working on 1015pn

    Nope! I did not see that... and it worked!

    I did not think to try all the different profiles in Step 6~ I had assumed that Digital Stereo Output (HDMI) was the correct one.


    Now I have another problem, though. In the "Output" tab, I have two things listed:

    -High Definition Audio Controller
    -High Definition Audio Controller Digital Stereo (HDMI) nr 2

    The HDMI audio only works when the second one is selected.

    However, every time I reboot, it changes back to the first one and the HDMI audio does not work again until I change the setting.

    I have already disabled "Internal Audio" under the Hardware tab.


    Thanks! and thanks! That was seriously driving me nuts

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •