Results 1 to 7 of 7

Thread: 11.04 "Device not ready"

  1. #1
    Join Date
    Jul 2011
    Beans
    3

    [SOLVED] 11.04 "Device not ready"

    Hey guys,

    I have a Lenovo ThinkPad Edge E520 (1143CTO) and I'm having problems getting my wireless NIC to work, as far as I can tell the drivers and firmware are all installed and the device is working.

    I have searched around and have done all the fixes I can find online, this is my first 'real' experience with Linux, so patience is appreciated, as is any help I can get. I also had this problem with Linux Mint 11.

    It appears that the model of my card is BCM43224, but it doesn't show up anywhere in the with any commands?

    sudo lshw

    *-network DISABLED
    description: Wireless interface
    product: Broadcom Corporation
    vendor: Broadcom Corporation
    physical id: 0
    bus info: pci@0000:09:00.0
    logical name: eth2
    version: 01
    serial: ac:81:12:3e:1d:ca
    width: 64 bits
    clock: 33MHz
    capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
    configuration: broadcast=yes driver=wl0 driverversion=5.100.82.38 latency=0 multicast=yes wireless=IEEE 802.11abgn
    resources: irq:19 memory:e1d00000-e1d03fff
    sudo lspci

    09:00.0 Network controller: Broadcom Corporation Device 0576 (rev 01)
    I have tried the Broadcom STA drivers and have also tried the command:
    sudo apt-get install b43-fwcutter firmware-b43-installer
    sudo rfkill list

    0: brcmwl-0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
    Yet, sudo lshw still shows it as disabled!

    Nothing I can find just seems to work. Any help at all is appreciated and I will try any suggestions as-long as you can provide me with the command

    I have tried EVERY fix I can find!

    P.S. This is the fourth forum I am posting it on as I am in desperate need of help.

    Thanks.
    Last edited by Bocaj1994; July 12th, 2011 at 03:49 AM.

  2. #2
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    19,443
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: 11.04 "Device not ready"

    Please post:
    Code:
    lspci -nn | grep 0280
    sudo rfkill list all
    dmesg | grep -e b43 -e wl
    lsmod | grep -e b43 -e wl
    The pipe symbol | is on the right side of my US keyboard on the same key with \. Thanks.
    Chili's Folly: Intel NUC, i3-4010U, 120 GB SSD, 16 GB RAM, external 500 GB HDD, Ubuntu Saucy; small, silent and fast.

  3. #3
    Join Date
    Jul 2011
    Beans
    3

    Re: 11.04 "Device not ready"

    I see you are helping alot of people with this problem, sadly their solutions don't work for me. I appreciate your help!

    > lspci -nn | grep 0280

    Code:
    09:00.0 Network controller [0280]: Broadcom Corporation Device [14e4:0576] (rev 01)
    > sudo rfkill list all

    Code:
    0: brcmwl-0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
    1: acer-wireless: Wireless LAN
        Soft blocked: yes
        Hard blocked: no
    2: tpacpi_bluetooth_sw: Bluetooth
        Soft blocked: yes
        Hard blocked: no
    > dmesg | grep -e b43 -e wl

    Code:
    [   11.211707] wl 0000:09:00.0: PCI INT A -> GSI 19 (level, low) -> IRQ 19
    [   11.211720] wl 0000:09:00.0: setting latency timer to 64
    > lsmod | grep -e b43 -e wl

    Code:
    wl                   2568244  0 
    lib80211               14991  2 lib80211_crypt_tkip,wl
    Thanks again!

  4. #4
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    19,443
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: 11.04 "Device not ready"

    acer-wireless: Wireless LAN
    Soft blocked: yes
    That means, roughly, that software is blocking the wireless. In this case, I suspect the module acer-wmi is not telling the kernel that the wireless switch is on or off.

    Hey! Wait a minute! An Acer module on a Lenovo?? Well, it's a known bug: https://bugs.launchpad.net/ubuntu/+s...ux/+bug/668234

    Let's check:
    Code:
    lsmod | grep acer
    If acer-wmi is loaded, let's unload it:
    Code:
    sudo rmmod -f acer-wmi
    Did your wireless spring to life? If so, let's blacklist it:
    Code:
    sudo su
    echo "blacklist acer-wmi" >> /etc/modprobe.d/blacklist.conf
    exit
    If that doesn't fix it, post back and we'll dig deeper.
    Chili's Folly: Intel NUC, i3-4010U, 120 GB SSD, 16 GB RAM, external 500 GB HDD, Ubuntu Saucy; small, silent and fast.

  5. #5
    Join Date
    Jul 2011
    Beans
    3

    Re: 11.04 "Device not ready"

    I... Love... You!

    I did see that acer wireless somewhere else on a forum but they seemed to ignore that and it worked?

  6. #6
    Join Date
    Jul 2011
    Beans
    8

    Re: 11.04 "Device not ready"

    Thank you.
    I had the same problem on a Lenovo B560

  7. #7
    Join Date
    Dec 2010
    Location
    Land of the Free!
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: 11.04 "Device not ready"

    My god, your a genius! worked on my e520 as well! You must be RMS. Please accept 12 Internets.
    THE TRUTH HAS NO AGENDA...
    "There is no "Good" or "Evil", only Power and Weakness, and those who fail to see this."- The Dark Lord

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •