Hi

Please help me regarding installation of subjected problems, I can't troubleshoot as I am new, as I search some threads but they couldn't help me out.

Code:
sudo apt-get install emacs21
Output
HTML Code:
khan@khan:~$sudo apt-get install emacs21
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package emacs21 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package emacs21 has no installation candidate
Then for skype
Code:
sudo apt-get install skype
Output
HTML Code:
khan@khan:~$ sudo apt-get install skype
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  skype: Depends: libqt4-dbus (>= 4:4.5.3) but it is not installable
         Depends: libqt4-network (>= 4:4.5.3) but it is not installable
         Depends: libqtcore4 (>= 4:4.5.3) but it is not installable
         Depends: libqtgui4 (>= 4:4.5.3) but it is not installable
E: Broken packages
I thank you in advance !