Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Backtrack 5 tools in 11.04

  1. #1
    Join Date
    Sep 2009
    Beans
    28

    Backtrack 5 tools in 11.04

    Hello,

    I recently got my macbookpro5,5 fully working with Ubuntu 11.04. One question i have though, is would it be possible to add the backtrack 5 tools (i.e. a repository, etc.) into this build of Ubuntu?

    I tried following these steps (http://www.zimbio.com/Ubuntu+Linux/a...cations+Ubuntu), but i am unable to ping: repo.offensive-security.com (which leads me to believe they changed the repo).

    Any help is appreciated!

    Thanks,
    Ben

  2. #2
    wojox is offline I Ubuntu, Therefore, I Am
    Join Date
    Apr 2009
    Beans
    8,630

    Re: Backtrack 5 tools in 11.04

    Use the archives http://archive.offensive-security.com/

    I would recommend downloading the Gnome version onto a usb stick.

  3. #3
    Join Date
    Feb 2009
    Location
    Scranton Pa
    Beans
    1
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Backtrack 5 tools in 11.04

    The repo is added by doing the following:
    get the GPG key:
    wget -q http://archive.offensive-security.com/backtrack.gpg -O- | sudo apt-key add -

    Add the main repo:
    sudo echo "deb http://archive.offensive-security.com pwnsauce main microverse macroverse restricted universe multiverse" > /etc/apt/sources.list

    Add the testing repo:
    sudo echo "deb http://sun.offensive-security.com/repotest/ ./" >> /etc/apt/sources.list

    reference info from:
    http://sun.backtrack-linux.org/README.txt

  4. #4
    Join Date
    Sep 2009
    Beans
    28

    Re: Backtrack 5 tools in 11.04

    Quote Originally Posted by lajjr View Post
    The repo is added by doing the following:
    get the GPG key:
    wget -q http://archive.offensive-security.com/backtrack.gpg -O- | sudo apt-key add -

    Add the main repo:
    sudo echo "deb http://archive.offensive-security.com pwnsauce main microverse macroverse restricted universe multiverse" > /etc/apt/sources.list

    Add the testing repo:
    sudo echo "deb http://sun.offensive-security.com/repotest/ ./" >> /etc/apt/sources.list

    reference info from:
    http://sun.backtrack-linux.org/README.txt
    Thanks Lajjr, would this install the backtrack 5 tools?

    Looking at the Readme (via the URL), it seems to reference backtrack 4.

  5. #5
    Join Date
    Jun 2011
    Beans
    4

    Wink Re: Backtrack 5 tools in 11.04

    just install bt5 in your hard drive

    and do

    1 - change the password with

    > passwd

    and write your old and your new password

    2 - apt-get install synaptic

    3 - in synaptic go to repository

    tick the ubuntu main 10.04 repository

    3 - apt-get update && apt-get upgrade

    4 - apt-get install sofware-center && apt-get install .....(all the package where you know the name)......

    then if you do a "software-center" in a shell it will launch it , free to you making a quickstart wtih this command line.
    so you can install everything you want

    5 - do the same for every soft or function in ubuntu with apt-get or software-center or synaptic . more exemple : libre office, deluge, pdf reader, pidgin, skype, chrome....

    6 - you have to forget unity and ubuntu 11.04, bt5 is based on 10.04, and gnome2 is quite better than unity, wait gnome3 is operationnal. you can try to do a apt-get install unity with the good repository for unity (add it wih synaptic)

    7 - Enjoy , so easy make your customisabled bt5 distrib, the power of ubuntu core and bt5 tools.

    so it's easier to activate ubuntu main repository than to activate bt5 repository in the latest release of ubuntu.

    bt5 is a very good distrib ubuntu-based, try with virtualbox before.
    the bt5 developper team keep one version less for more stability.

    [SOLVED]

  6. #6
    Join Date
    Jun 2011
    Location
    southern, WV
    Beans
    5
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Backtrack 5 tools in 11.04

    Quote Originally Posted by boodoo View Post
    just install bt5 in your hard drive


    7 - Enjoy , so easy make your customisabled bt5 distrib, the power of ubuntu core and bt5 tools.

    so it's easier to activate ubuntu main repository than to activate bt5 repository in the latest release of ubuntu.


    [SOLVED]
    I would go with boodoo on this, I did the bt 5 install, and added the right repos, and it's just like I implemented bt 5 straight into Ubuntu 10.04, especially after some sweet customizing

  7. #7
    Join Date
    Mar 2008
    Beans
    1

    Thumbs down Re: Backtrack 5 tools in 11.04

    Quote Originally Posted by boodoo View Post
    just install bt5 in your hard drive

    and do

    1 - change the password with

    > passwd

    and write your old and your new password

    2 - apt-get install synaptic

    3 - in synaptic go to repository

    tick the ubuntu main 10.04 repository

    3 - apt-get update && apt-get upgrade

    4 - apt-get install sofware-center && apt-get install .....(all the package where you know the name)......

    then if you do a "software-center" in a shell it will launch it , free to you making a quickstart wtih this command line.
    so you can install everything you want

    5 - do the same for every soft or function in ubuntu with apt-get or software-center or synaptic . more exemple : libre office, deluge, pdf reader, pidgin, skype, chrome....

    6 - you have to forget unity and ubuntu 11.04, bt5 is based on 10.04, and gnome2 is quite better than unity, wait gnome3 is operationnal. you can try to do a apt-get install unity with the good repository for unity (add it wih synaptic)

    7 - Enjoy , so easy make your customisabled bt5 distrib, the power of ubuntu core and bt5 tools.

    so it's easier to activate ubuntu main repository than to activate bt5 repository in the latest release of ubuntu.

    bt5 is a very good distrib ubuntu-based, try with virtualbox before.
    the bt5 developper team keep one version less for more stability.

    [SOLVED]


    Will You Marry Me?
    just think all these magic tools together in a flash drive
    Last edited by zartas; July 10th, 2011 at 03:05 PM.

  8. #8
    Join Date
    Jul 2011
    Beans
    1

    Re: Backtrack 5 tools in 11.04

    I can install drivers for my Broadcom Wireless on Ubuntu 11.04 (and Ati driver works well too) I installed Backtrack 5, and followed your steps. At jockey-gtk both driver get error again and again At Ubuntu 11.04 they didn't stucked. I have now [backtrack5 gnome 64]

  9. #9
    Join Date
    Nov 2011
    Beans
    1

    Re: Backtrack 5 tools in 11.04

    this helped me alot thanks!!

  10. #10
    Join Date
    Jun 2011
    Beans
    4

    Re: Backtrack 5 tools in 11.04

    After working a bit more on bt5, lot of package are done to be used as root, and bt5 use specific kernel header.

    So if you activate ubuntu main repositories, you will crush some BT5 system package. some of package of bt5 ppa won't work anymore correctly with ubuntu main repositorie activated.

    More over don't install proprietary graphic driver like ATI or Nvidia. They should work but you won't use anymore BT5 GPU based calculs. Like Pyrit etc...

    Best pratice are following:

    1 - change root pswd

    2 - (All accessible from bt5 ppa)
    sudo apt-get install synaptic sofware-center open-office banshee chromium pidgin apache2 php5 etc ......

    3 - never active ubuntu main repositories

    4- eventualy, add PPA if you really need a specific app not present in bt5 repo, or dld the .deb and do a dpkg --install packageName.deb but never ubuntu main repository,

    5 - BT5 ppa has a lot of accessible package used on ubuntu

    5 - the only one problematic package is Skype, i success for all other daily used.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •