I am posting this in case anyone's had the same problem I have with two different generations of Eee PCs and two different Ubuntu versions (10.10 and 11.04).

Wireless connected quickly and did not freeze the laptop. However, the loading of pages took a long while as if trying to find domain name servers (DNS).

The problem, apparently, was the power management policy of the wireless card. This should be disabled.

To do this, follow these steps:
1. run in a terminal this command:
iwconfig
This is how you find out the interface of your wireless card. For me, it was wlan0 but it could be eth0, eth1 or other.

2. open a root nautilus:
sudo nautilus /etc/pm/power.d/

3. create an empty file with the name wireless in that directory.

3. enter the following in the newly created file, wireless (replace wlan0 with your interface if necessary):
#!/bin/sh
/sbin/iwconfig wlan0 power off

4. make sure your file is executable:
sudo chmod +x /etc/pm/power.d/wireless

5. restart or relogin in and see if problem persists.