Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Force Aspect Ratio in Smpalyer

  1. #1
    Join Date
    Jan 2010
    Location
    India
    Beans
    Hidden!
    Distro
    Lubuntu 14.04 Trusty Tahr

    Force Aspect Ratio in Smpalyer

    Hi, I want Smplayer to display all videos in 16:9 aspect ratio.

    I searched at google & found a solution here http://ubuntuforums.org/showthread.php?t=863779.

    Its working, with Gnome Mplayer but not with Smplayer.

    Smplayer still displays all videos in their default ARs.

    Suppose I arrange multiple videos in Smplayer's playlist I need to get up from my seat & change the AR, every time a new track starts playing. This is really tiresome.

    Please help
    Lubuntu 14.04 / Manjaro LXQT (openbox)
    Psychology fact: There's a story behind every person. There's a reason why they're the way they are. Pain alters our personality.

  2. #2
    Join Date
    Sep 2009
    Beans
    2,330

    Re: Force Aspect Ratio in Smpalyer

    see if setting it in totem helps

  3. #3
    Join Date
    Jan 2010
    Location
    India
    Beans
    Hidden!
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: Force Aspect Ratio in Smpalyer

    Quote Originally Posted by no2498 View Post
    see if setting it in totem helps
    Thanks for your reply.

    Since most of my videos are high definition, vdpau is something I can't do without. Previously vlc was the only player I used but since it is not yet capable of using vdpau efficiently I only use Smplayer & Gnome Mplayer.

    A) Settings in Totem doesn't allow to specify AR
    &
    B) I just played a 1080 video in Totem. The cpu usage was in the 50s.
    Lubuntu 14.04 / Manjaro LXQT (openbox)
    Psychology fact: There's a story behind every person. There's a reason why they're the way they are. Pain alters our personality.

  4. #4
    Join Date
    Jan 2010
    Location
    India
    Beans
    Hidden!
    Distro
    Lubuntu 14.04 Trusty Tahr

    Angry Re: Force Aspect Ratio in Smpalyer

    If someone is sure of the fact that forcing aspect ration in not possible in Smplayer, kindly reply.
    Lubuntu 14.04 / Manjaro LXQT (openbox)
    Psychology fact: There's a story behind every person. There's a reason why they're the way they are. Pain alters our personality.

  5. #5
    Join Date
    Jan 2010
    Location
    India
    Beans
    Hidden!
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: Force Aspect Ratio in Smpalyer

    If someone is sure of the fact that forcing aspect ratio is not possible in Smplayer ...... please reply.
    Last edited by linuxyogi; January 14th, 2011 at 04:18 PM.
    Lubuntu 14.04 / Manjaro LXQT (openbox)
    Psychology fact: There's a story behind every person. There's a reason why they're the way they are. Pain alters our personality.

  6. #6
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    8,724
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: Force Aspect Ratio in Smpalyer

    Try these:

    Preferences > Advanced > Monitor Aspect > 16:9

    or maybe

    Video > Aspect Ratio > 16:9

    You can also try passing mplayer options via

    Preferences > Advanced > Options for MPlayer

    try adding "-monitoraspect 16:9" in that box, though I'm guessing the "Monitor Aspect" setting does the same thing.

    See "man mplayer" for more possibilities. Anything mplayer supports can be utilized via smplayer by adding the appropriate options to "Options for MPlayer."
    Last edited by SeijiSensei; January 14th, 2011 at 04:07 PM.

  7. #7
    Join Date
    Jan 2010
    Location
    India
    Beans
    Hidden!
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: Force Aspect Ratio in Smpalyer

    Quote Originally Posted by SeijiSensei View Post
    Try these:

    Preferences > Advanced > Monitor Aspect > 16:9

    or maybe

    Video > Aspect Ratio > 16:9

    "
    Preferences > Advanced > Monitor Aspect > 16:9

    was already selected.

    Video > Aspect Ratio > 16:9

    Works. But doesn't change the AR permanently.

    Quote Originally Posted by SeijiSensei View Post
    Preferences > Advanced > Options for MPlayer

    try adding "-monitoraspect 16:9" in that box, though I'm guessing the "Monitor Aspect" setting does the same thing.
    Just tried that. Didn't work.

    Quote Originally Posted by SeijiSensei View Post
    See "man mplayer" for more possibilities.
    Working on it.

    Thanks.
    Lubuntu 14.04 / Manjaro LXQT (openbox)
    Psychology fact: There's a story behind every person. There's a reason why they're the way they are. Pain alters our personality.

  8. #8
    Join Date
    Jan 2010
    Location
    India
    Beans
    Hidden!
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: Force Aspect Ratio in Smpalyer

    Just found this using man mplayer.

    Code:
    mplayer aspect=16/9 filename.avi
    It works from the command line.
    But doesn't work when used in the "mplayer options" in Smplayer.
    Lubuntu 14.04 / Manjaro LXQT (openbox)
    Psychology fact: There's a story behind every person. There's a reason why they're the way they are. Pain alters our personality.

  9. #9
    Join Date
    Jan 2010
    Location
    India
    Beans
    Hidden!
    Distro
    Lubuntu 14.04 Trusty Tahr

    Angry Re: Force Aspect Ratio in Smpalyer

    Guys .............Please
    Lubuntu 14.04 / Manjaro LXQT (openbox)
    Psychology fact: There's a story behind every person. There's a reason why they're the way they are. Pain alters our personality.

  10. #10
    Join Date
    Jan 2011
    Location
    Indianapolis IN, USA
    Beans
    139
    Distro
    Lubuntu 11.10 Oneiric Ocelot

    Re: Force Aspect Ratio in Smpalyer

    This won't make them all 16/9, but I think it will do for you. Go to Preference's, Advance, and in the space where it says "Run the following....." put aspect_none. That will make the video stretch to full screen. However, if you are watching from a video it does still change the size you need to turn off auto resize for that.

    I know it is a bit late, but I saw this post while search for it myself, and thought who knows, maybe you havn't found a fix yet.
    Last edited by Theredbaron1834; May 18th, 2011 at 08:41 PM.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •