Results 1 to 4 of 4

Thread: Re: 11.04 trashed all my localhost links!!!

  1. #1
    Join Date
    Dec 2007
    Location
    Livercool, UK
    Beans
    45
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: 11.04 trashed all my localhost links!!!

    So ok, I decided to upgrade to Ubuntu 11.04 from MearKat and 11.04 trashes my localhost projects - any resolve as I don't want to really start all over again as I've spent a good 20 hours.
    My SQL DB's are still there but all the internal links both front and backend show to good old:


    "Not Found

    The requested URL /project01/admin/modules was not found on this server.
    Apache/2.2.17 (Ubuntu) Server at localhost Port 80"


    I would like to resolve the problem, can any onwe give any quick fixes for me??


    "If it ain't broke don't fix it" rules here but I had faith in the 11.04 upgrade so went forward at the w/end. Usually I wait at least 6 weeks before doing so.

    PB

  2. #2
    Join Date
    Oct 2009
    Location
    Upminster, Essex, UK
    Beans
    544

    Re: 11.04 trashed all my localhost links!!!

    Not really enough to go on at the mo BUT I would have though any virtualhosts defined in sites-available and quite probably your hosts file would have suffered some damage

    You do keep backups right?
    Code:
    cd /fridge/beer | drink && fallover

  3. #3
    Join Date
    Dec 2007
    Location
    Livercool, UK
    Beans
    45
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: 11.04 trashed all my localhost links!!!

    Quote Originally Posted by satanselbow View Post
    Not really enough to go on at the mo BUT I would have though any virtualhosts defined in sites-available and quite probably your hosts file would have suffered some damage

    You do keep backups right?
    Backsups... of course, just don't want to have to put antoehr hat on.

    Anyone care to offer a simple fix to resolve the lost localhost connections?

    PB

  4. #4
    Join Date
    Dec 2007
    Location
    Livercool, UK
    Beans
    45
    Distro
    Ubuntu 11.04 Natty Narwhal

    RESOLVED - Re: 11.04 trashed all my localhost links!!!

    Error stems from Apache2 re-install in DIR in ETC dir, ie: AllowOverride All and NOT none.
    If running Linux and you have re-installed Ubuntu 11.04, suggest you open Default and cut and paste below into file then save.
    This resolved all my virtual sites to normal, pre-upgrade.

    Default file should read:

    ServerAdmin webmaster@localhost

    DocumentRoot /var/www

    Options FollowSymLinks
    AllowOverride All

    Options Indexes FollowSymLinks MultiViews
    AllowOverride All
    Order allow,deny
    allow from all

    ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/

    AllowOverride All
    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
    Order allow,deny
    Allow from all

    ErrorLog /var/log/apache2/error.log

    # Possible values include: debug, info, notice, warn, error, crit,
    # alert, emerg.
    LogLevel warn

    CustomLog /var/log/apache2/access.log combined

    Alias /doc/ "/usr/share/doc/"

    Options Indexes MultiViews FollowSymLinks
    AllowOverride All
    Order deny,allow
    Deny from all
    Allow from 127.0.0.0/255.0.0.0 ::1/128

    ---ends.

    Hope that helps any peeps in future.
    Paul B

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •