Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Recordings suddenly gone?

  1. #1
    Join Date
    Jul 2010
    Location
    Denmark
    Beans
    21

    Exclamation Recordings suddenly gone?

    Been away for some days on holiday and came back to a Myth with a lot of recordings. Recordings can be viewed on the web interface (and deleted).

    Local MythFrontend and remote states that there are no recordings - even though web sees it, and the files are there.

    Happended while I was gone.

    Anyone know how to get around this bug - all my recordings are quite ****** until I can get them to show on the frontends.

    No patches was applied (I was just away for 2 weeks)
    No filters are active when pressing M on the recordings screen.
    LiveTV works fine
    Seems to record new programs as it should

    Help is really needed - thanks in advance.

  2. #2
    Join Date
    Dec 2006
    Beans
    177

    Re: Recordings suddenly gone?

    Go into the main menu, and under System, enter the Backend Setup, saying yes to the prompt. When you are in the Setup, escape out, run/don't run Mythfilldatabase as you wish, bring the frontend back up, this should solve your problem. I get this same problem randomly at boot. There may be other solutions, but this one is the easiest I have found so far.

    It has something to do with the backend not starting before some other process, and thus, the frontend loses the connection to the backend... as I understand it.

  3. #3
    Join Date
    Jul 2010
    Location
    Denmark
    Beans
    21

    Re: Recordings suddenly gone?

    In general the system seems to be up - only recordings and recording schedules are missing? The trick with running backend setup and quitting have fixes issues before after a reboot - but this time it doesn't work.

  4. #4
    Join Date
    May 2007
    Beans
    2,334

    Re: Recordings suddenly gone?

    Hi,

    Do you see anything interesting in the backend log file? That's the best place to start. Maybe you have database corruption that's taken out your recorded table.

    Regards
    Ian Dobson
    Walking on water and writing software to specification is easy if they're frozen.

    My corner of the internet http://www.planet-ian.com

  5. #5
    Join Date
    Jul 2010
    Location
    Denmark
    Beans
    21

    Re: Recordings suddenly gone?

    Cleared the logs, restarted and checked the logs. Nothing there really? The web frontend shows the recordings though - but not the real frontend.

    This is from the frontend app, which runs with the backend directly.

    ---START ---
    Starting mythfrontend.real..
    2011-04-16 21:00:24.057 mythfrontend version: branches/release-0-23-fixes [26863] www.mythtv.org
    2011-04-16 21:00:24.058 Using runtime prefix = /usr
    2011-04-16 21:00:24.058 Using configuration directory = /home/mtv/.mythtv
    2011-04-16 21:00:24.757 Empty LocalHostName.
    2011-04-16 21:00:24.757 Using localhost value of mtv-tsl-001
    2011-04-16 21:00:24.764 New DB connection, total: 1
    2011-04-16 21:00:24.768 Connected to database 'mythconverg' at host: localhost
    2011-04-16 21:00:24.770 Closing DB connection named 'DBManager0'
    2011-04-16 21:00:24.781 ScreenSaverX11Private: XScreenSaver support enabled
    2011-04-16 21:00:24.782 DPMS is disabled.
    2011-04-16 21:00:24.784 Primary screen: 0.
    2011-04-16 21:00:24.785 Connected to database 'mythconverg' at host: localhost
    2011-04-16 21:00:24.786 Using screen 0, 1024x768 at 0,0
    2011-04-16 21:00:24.800 MythXGetRefreshRate(): X11 ModeLine query returned zeroes
    2011-04-16 21:00:24.801 Desktop video mode: 0x0 0 Hz
    2011-04-16 21:00:24.822 MythUI Image Cache size set to 20971520 bytes
    2011-04-16 21:00:24.844 Enabled verbose msgs: important general
    2011-04-16 21:00:24.851 Primary screen: 0.
    2011-04-16 21:00:24.851 Using screen 0, 1024x768 at 0,0
    2011-04-16 21:00:24.852 Using theme base resolution of 1280x720
    2011-04-16 21:00:24.856 LIRC, Error: Failed to connect to Unix socket '/dev/lircd'
    eno: No such file or directory (2)
    2011-04-16 21:00:24.856 JoystickMenuThread Error: Joystick disabled - Failed to read /home/mtv/.mythtv/joystickmenurc
    2011-04-16 21:00:24.891 Using Frameless Window
    2011-04-16 21:00:24.891 Using Full Screen Window
    2011-04-16 21:00:25.070 Using the Qt painter
    2011-04-16 21:00:25.288 XMLParseBase: Loaded base theme from '/usr/share/mythtv/themes/Mythbuntu/base.xml'
    2011-04-16 21:00:25.298 XMLParseBase: Loaded base theme from '/usr/share/mythtv/themes/default-wide/base.xml'
    2011-04-16 21:00:25.304 XMLParseBase: Loaded base theme from '/usr/share/mythtv/themes/default/base.xml'
    2011-04-16 21:00:25.304 XMLParseBase, Error: Unable to load window 'backgroundwindow' from base
    2011-04-16 21:00:25.327 Current MythTV Schema Version (DBSchemaVer): 1254
    2011-04-16 21:00:25.780 Registering Internal as a media playback plugin.
    2011-04-16 21:00:25.804 Cannot load language en_us for module mytharchive
    2011-04-16 21:00:25.828 MediaMonitorUnix::AddDevice() - empty device path.
    2011-04-16 21:00:25.829 MediaMonitorUnix::AddDevice() - empty device path.
    2011-04-16 21:00:25.829 MediaMonitorUnix::AddDevice() - empty device path.
    2011-04-16 21:00:25.830 MonitorRegisterExtensions(0x100, gif,jpg,png)
    2011-04-16 21:00:25.830 Cannot load language en_us for module mythgallery
    2011-04-16 21:00:25.832 Cannot load language en_us for module mythmovies
    2011-04-16 21:00:25.851 Current MythMusic Schema Version (MusicDBSchemaVer): 1017
    2011-04-16 21:00:25.886 MonitorRegisterExtensions(0x40, mp3,mp2,ogg,oga,flac,wma,wav,ac3,oma,omg,atp,ra,dt s,aac,m4a,aa3,tta,mka,aiff,swa,wv)
    2011-04-16 21:00:25.891 Cannot load language en_us for module mythmusic
    2011-04-16 21:00:25.897 Current MythVideo Schema Version (mythvideo.DBSchemaVer): 1032
    2011-04-16 21:00:25.921 Cannot load language en_us for module mythvideo
    2011-04-16 21:00:25.926 Cannot load language en_us for module mythweather
    2011-04-16 21:00:25.928 XMLParseBase: Loading window theme from /usr/share/mythtv/themes/Mythbuntu/menu-ui.xml
    2011-04-16 21:00:26.008 Loading menu theme from /usr/share/mythtv/themes/defaultmenu//mainmenu.xml
    2011-04-16 21:00:26.012 Found mainmenu.xml for theme 'Mythbuntu'
    2011-04-16 21:00:26.809 MythContext: Connecting to backend server: 172.30.1.5:6543 (try 1 of 1)
    2011-04-16 21:00:26.810 Using protocol version 23056
    2011-04-16 21:00:28.430 Loading menu theme from /usr/share/mythtv/themes/defaultmenu//library.xml
    2011-04-16 21:00:29.293 New DB connection, total: 2
    2011-04-16 21:00:29.293 Connected to database 'mythconverg' at host: localhost
    2011-04-16 21:00:29.295 XMLParseBase: Loading window theme from /usr/share/mythtv/themes/Mythbuntu/recordings-ui.xml
    length mismatch between programinfo
    2011-04-16 21:00:29.519 PlaybackBox Error: SortedList is Empty
    2011-04-16 21:00:29.635 PlaybackBox Error: SortedList is Empty
    2011-04-16 21:00:33.149 Loading menu theme from /usr/share/mythtv/themes/defaultmenu//manage_recordings.xml
    2011-04-16 21:00:34.342 XMLParseBase: Loading window theme from /usr/share/mythtv/themes/Mythbuntu/schedule-ui.xml
    2011-04-16 21:00:34.419 ProgramInfo(): FromStringList, not enough items in list.
    2011-04-16 21:00:34.419 LoadFromScheduler(): Length mismatch.
    2011-04-16 21:00:36.862 Deleting UPnP client...
    --- end ---

    There are a few errors of some sort - but nothing that helps me here.

    Additional note - deleting recordings from the webfrontend is really slow now???

    Thanks for any input.....
    Last edited by rvindum; April 16th, 2011 at 08:10 PM.

  6. #6
    Join Date
    Mar 2008
    Beans
    1,086

    Re: Recordings suddenly gone?

    I suppose you've already done the usual thing when the database is having a crash or corruption problem with one of its tables, which is to run

    mysqlcheck --auto-repair mythconverg

    or maybe

    mysqlcheck --auto-repair --all-databases

    on it?

  7. #7
    Join Date
    Jul 2010
    Location
    Denmark
    Beans
    21

    Re: Recordings suddenly gone?

    Hi there.

    Nope, but did it now - and no luck
    States ok on all tables and nothing has changed after this....

    \René
    Last edited by rvindum; April 17th, 2011 at 01:04 PM.

  8. #8
    Join Date
    Jul 2010
    Location
    Denmark
    Beans
    21

    Re: Recordings suddenly gone?

    Seems the following command works:

    mysql -u root -p -D mythconverg -E --default-character-set=utf8 -e "UPDATE recorded SET subtitle=REPLACE(subtitle, '\0', '');"

    Found a discussions about this, where the error seemed to come frome the EIT and caused unsupported chars in the database.

    Just tried it, and it seemed to work - don't know if the error returns after next recording, but time will tell.

  9. #9
    Join Date
    Mar 2008
    Beans
    1,086

    Re: Recordings suddenly gone?

    Well done! It's good to have a fix like this documented in this particular forum.

    Though I'm surprised that MySQL allows the login for root --usually the only authorized user in a Mythbuntu installation is "mythtv"

    I suppose that if the symptoms recur after particular events (rebooting, say, or after some recordings) it would seem that a one-line script incorporating this command (but with the -p parameter specified) would be very easy to have the system run wherever appropriate (somewhere under /etc/init.d, or as an hourly cron job or whatever).

  10. #10
    Join Date
    Jul 2010
    Location
    Denmark
    Beans
    21

    Re: Recordings suddenly gone?

    As far as I could find in the danish forum about the bug I had, it was caused by the Electronical Program Guide - and a fix was posted on the Myth patchlist.

    Old bugs was to be removed by hand though - and not sure this patch was released on the .23 version though.

    Will upgrade later on - but just glad that my recordings are back.

    Thanks all for feedback and ideas.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •