I've figured out the fax, although it works in kind of a roundabout way.

For the MFC-J615W, there are two ways of using the fax from your Ubuntu PC:

- using the LPR and CUPS-wrapper drivers

- using the fax-modem driver, which is made specifically for Ubuntu and specifically for Ubuntu 10.10

The LPR and CUPS-wrapper drivers can't be used ("printed" to) from programs in the way you would with other CUPS printers. If you print to it, nothing happens - the MFC wakes up and indicates "receiving data", the print spool will indicate that the MFC is receiving 0 bytes out of [whatever] and just sit there.

You have to use Brother's command-line-only brpcfax as stated in the Brother instructions:

brpcfax  -o  fax-number=(fax-number)  (filename)
and it only accepts .ps (PostScript) files. Making .ps files is a little clunky, the easiest way is to open or create the file in OpenOffice, then select print, specifying "Print to File" in the checkbox. I'm using BRFAX as the printer but I think any PostScript printer would work (the Brother printer, others). All it's doing is converting the text and images to PostScript, which you then fax.

So - not very direct.

I sent a test file (not a .ps file though) this way and the printer woke up and started dialing, so I think it should work if you can make a .ps file.

I also haven't thoroughly tested it out, but the fax-modem driver method through Efax should work OK. However it's limited to USB only as explained in the Brother instructions. The Brother instructions tell you to modify /etc/efax.rc, changing DEV from ttyS1 to modem. You should also modify the other parameters like your name, your telephone number, etc.

However this is for the Efax command-line program. If you're using the Efax-gtk graphical frontend, it has a separate configuration file. You should be able to modify it using Efax-gtk - File - Settings but for some reason I couldn't alter the settings, it would revert to what it was before when I exited the program. Efax-gtk uses a separate configuration file at /etc/efax-gtkrc which can only be altered as root, so use:

gksudo gedit /etc/efax-gtkrc
change DEV to modem and alter your name, telephone number, paper settings, etc.

Unfortunately while Efax-gtk is more user-friendly than brpcfax, it will still only accept .ps files, although it will also accept plain text files according to its description in Synaptic.

Could be better I guess, but the otherwise flawless operation of this printer in Ubuntu Linux makes up for it.