Results 1 to 5 of 5

Thread: Transmit audio over network

  1. #1
    Join Date
    Feb 2010
    Location
    Belgium
    Beans
    66
    Distro
    Ubuntu 10.04 Lucid Lynx

    Question Transmit audio over network

    Here's my situation:

    I have a laptop running Ubuntu 10.04 LTS which is connected to a wifi home network. In my bedroom I have a data server running Ubuntu 10.04 LTS which is also connected to the same network and connected to a stereo with speakers across the room. Is it possible to play music on my laptop but, instead of playing it through the speakers of my laptop, transmit the audio stream over the network to the data server which plays the music on the big stereo?

    If it is possible, how do I do it?

    Thanks!

  2. #2
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,905
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Transmit audio over network

    If you have pulseaudio installed on both, paprefs (pulseaudio preferences) should do the trick.
    Code:
    Alt+F2
    paprefs
    To install using terminal:
    Code:
    sudo apt-get install paprefs

  3. #3
    Join Date
    Feb 2010
    Location
    Belgium
    Beans
    66
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Transmit audio over network

    OK, have been fiddling with the settings and now, I have NO audio, at all... crap!

    Help?

  4. #4
    Join Date
    Nov 2007
    Location
    South Dakota
    Beans
    17
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Transmit audio over network

    Hi,

    Could you post a description of the actions you took, when the last time you know your sound worked was, and what you have changed since then?

    Are you sure that the pulseaudio daemon is running?

    Here is a thread which may or may not be related.

  5. #5
    Join Date
    Feb 2010
    Location
    Belgium
    Beans
    66
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Transmit audio over network

    Well, I have actually no idea of what I have done. It something to do with creating an RTP sender on the laptop and an RTP receiver on the server. I remember I clicked the 'create seperate device for RTP'-box and then switched in the non-pulseaudio volume control thingy the output from my speakers to the RTP device... This (logically) killed my audio on the laptop and I could see an audio signal going through the RTP channel in the pulseaudio volume control, output devices tab. However, nothing came through at the server side...

    Now, I've kinda unchecked every check box I found and my audio is up and running again on my laptop.

    I want to be able to simply switch the output device from local speakers to server speakers on my laptop...
    Any thoughts?

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •