Results 1 to 5 of 5

Thread: encoding video with only one long frame

  1. #1
    Join Date
    Oct 2009
    Beans
    3

    encoding video with only one long frame

    Hi, everyone!

    I'm sorry but I feel kind of incompetent, cause I'm trying to encode a video using only one image during a complete audio file, but a can't find the way to do it.
    What I need to do is to extend the duration of the frame up to the duration of the audio file. How do I do that with mencoder?
    Thanks
    tdy

  2. #2
    Join Date
    Jul 2006
    Location
    Lancashire
    Beans
    Hidden!
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: encoding video with only one long frame

    Quote Originally Posted by tdy View Post
    How do I do that with mencoder?

    tdy
    Hi
    I don't know how to do that with mencoder, but it's very easy using ffmpeg instead.

  3. #3
    Join Date
    Oct 2009
    Beans
    3

    Re: encoding video with only one long frame

    Sorry Ron999 but I'm having the same isue with ffmpeg as with ffmpeg.

    I get just a 1s video.

    what i need would be like:

    mycommandline:# ffmpeg -i audiofile.wav -i img.jpg mymovie.avi

    the thing is that ffmpeg or mencoder use as preority for the video duration the image file. Or better the fps option and that gives me a 1s of video with sound but not the actual 3.30 minutes the audio file have.

    how can I can tell to mencoder or ffmpeg that the frame lasted instead of 1s, 3.30 min?
    Enyone knows?

    Thanks again!

    tdy.

  4. #4
    Join Date
    Jul 2006
    Location
    Lancashire
    Beans
    Hidden!
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: encoding video with only one long frame

    Hi
    It's easiest to use a jpg or png image together with an mp3 or aac/m4a audio file to make an mp4 video.
    Like this:-
    Code:
    ffmpeg -loop_input -i img.jpg -i audiofile.mp3 -shortest -b 1000k -acodec copy mymovie.mp4
    This will give you a movie same duration as the audiofile.

    If you want to specify a certain duration hh:mm:ss use this instead (example 90 seconds):-
    Code:
    ffmpeg -loop_input -i img.jpg -i audiofile.mp3 -t 00:01:30 -b 1000k -acodec copy movie90.mp4
    Last edited by ron999; January 27th, 2011 at 11:45 PM.

  5. #5
    Join Date
    Oct 2009
    Beans
    3

    Re: encoding video with only one long frame

    Thanks Ron999!!! that realy works
    Definitly I've pass over the -loop_input parameter in the man page.

    Great help!!!

    tdy.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •