@_cvt_

I am facing the same issue.

Surprisingly I am able to connect using network manager

Successful connection using Network Manager (ubuntu 10.10 native)


Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> Activation (wlan0) starting connection 'Auto safari'
Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> (wlan0): device state change: 3 -> 4 (reason 0)
Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...
Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) started...
Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...
Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.
Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) starting...
Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> (wlan0): device state change: 4 -> 5 (reason 0)
Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> (wlan0): bringing up device.
Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> Activation (wlan0/wireless): access point 'Auto safari' has security, but secrets are required.
Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> (wlan0): device state change: 5 -> 6 (reason 0)
Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...
Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) started...
Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> (wlan0): device state change: 6 -> 4 (reason 0)
Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...
Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.
Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) starting...
Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> (wlan0): device state change: 4 -> 5 (reason 0)
Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> Activation (wlan0/wireless): connection 'Auto safari' has security, and secrets exist. No new secrets needed.
Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> Config: added 'ssid' value 'safari'
Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> Config: added 'scan_ssid' value '1'
Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> Config: added 'key_mgmt' value 'WPA-PSK'
Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> Config: added 'psk' value '<omitted>'
Jan 5 15:14:21 Latitude NetworkManager[1005]: nm_setting_802_1x_get_pkcs11_engine_path: assertion `NM_IS_SETTING_802_1X (setting)' failed
Jan 5 15:14:21 Latitude NetworkManager[1005]: nm_setting_802_1x_get_pkcs11_module_path: assertion `NM_IS_SETTING_802_1X (setting)' failed
Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> Config: set interface ap_scan to 1
Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> (wlan0): supplicant connection state: inactive -> disconnected
Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> (wlan0): supplicant connection state: disconnected -> scanning
Jan 5 15:14:23 Latitude wpa_supplicant[1130]: Trying to associate with 00:15:c7:fe:e0:60 (SSID='safari' freq=2437 MHz)
Jan 5 15:14:23 Latitude NetworkManager[1005]: <info> (wlan0): supplicant connection state: scanning -> associating
Jan 5 15:14:23 Latitude wpa_supplicant[1130]: Associated with 00:15:c7:fe:e0:60
Jan 5 15:14:23 Latitude NetworkManager[1005]: <info> (wlan0): supplicant connection state: associating -> associated
Jan 5 15:14:23 Latitude NetworkManager[1005]: <info> (wlan0): supplicant connection state: associated -> 4-way handshake
Jan 5 15:14:23 Latitude NetworkManager[1005]: <info> (wlan0): supplicant connection state: 4-way handshake -> group handshake
Jan 5 15:14:23 Latitude wpa_supplicant[1130]: WPA: Key negotiation completed with 00:15:c7:fe:e0:60 [PTK=TKIP GTK=TKIP]
Jan 5 15:14:23 Latitude wpa_supplicant[1130]: CTRL-EVENT-CONNECTED - Connection to 00:15:c7:fe:e0:60 completed (reauth) [id=0 id_str=]
Jan 5 15:14:23 Latitude NetworkManager[1005]: <info> (wlan0): supplicant connection state: group handshake -> completed
Jan 5 15:14:23 Latitude NetworkManager[1005]: <info> Activation (wlan0/wireless) Stage 2 of 5 (Device Configure) successful. Connected to wireless network 'safari'.




When I try doing so using terminal command line, getting to below issue :

Wireless event: cmd=0x8b15 len=20
Wireless event: new AP: 00:15:c7:fe:e0:60
Association info event
resp_ies - hexdump(len=42): 01 08 82 84 8b 0c 12 96 18 24 32 04 30 48 60 6c dd 18 00 50 f2 02 01 01 81 00 03 a4 00 00 27 a4 00 00 42 43 bc 00 62 32 66 00
State: ASSOCIATING -> ASSOCIATED
wpa_driver_wext_set_operstate: operstate 0->0 (DORMANT)
WEXT: Operstate: linkmode=-1, operstate=5
Associated with 00:00:00:00:00:00
WPA: Association event - clear replay counter
WPA: Clear old PTK
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
EAPOL: External notification - EAP success=0
EAPOL: External notification - portEnabled=1
EAPOL: SUPP_PAE entering state CONNECTING
EAPOL: SUPP_BE entering state IDLE
Setting authentication timeout: 10 sec 0 usec
Cancelling scan request
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b15 len=20
Wireless event: new AP: 00:00:00:00:00:00
Setting scan request: 0 sec 100000 usec
CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
wpa_driver_wext_set_key: alg=0 key_idx=0 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=1 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=2 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=3 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=0 set_tx=0 seq_len=0 key_len=0
State: ASSOCIATED -> DISCONNECTED



ctrl_interface=/var/run/wpa_supplicant

network={
ssid="safari"
scan_ssid=1
key_mgmt=WPA-PSK
pairwise=TKIP
group=TKIP
psk="key is mine"


All, Any help would appreciated !