Results 1 to 3 of 3

Thread: Seriously borked computer installing ffmpeg from svn

  1. #1
    Join Date
    Apr 2007
    Location
    New York
    Beans
    135
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Seriously borked computer installing ffmpeg from svn

    OMG PLEASE HELP!

    I'm running 10.10 and I have an ATI HD5470 and I was trying to add VAAPI support. I was told to compile and install a newer version of ffmpeg from SVN, which I did. I had to uninstall all the current/medibuntu libav* codecs to do so. I want to uninstall it but whenever I try to do anything in Synaptic it tries to reinstall the standard codecs before it can remove ffmpeg so it says

    Code:
    E: /var/cache/apt/archives/libavutil-extra-50_4%3a0.6-2ubuntu3+medibuntu1_i386.deb: trying to overwrite '/usr/lib/libavutil.so.50', which is also in package ffmpeg SVN-r25943-1
    E: /var/cache/apt/archives/libavformat-extra-52_4%3a0.6-2ubuntu3+medibuntu1_i386.deb: trying to overwrite '/usr/lib/libavformat.so.52', which is also in package ffmpeg SVN-r25943-1
    E: /var/cache/apt/archives/libswscale0_4%3a0.6-2ubuntu6_i386.deb: trying to overwrite '/usr/lib/libswscale.so.0', which is also in package ffmpeg SVN-r25943-1
    E: /var/cache/apt/archives/libavdevice52_4%3a0.6-2ubuntu6_i386.deb: trying to overwrite '/usr/lib/libavdevice.so.52', which is also in package ffmpeg SVN-r25943-1
    E: /var/cache/apt/archives/libpostproc51_4%3a0.6-2ubuntu6_i386.deb: trying to overwrite '/usr/lib/libpostproc.so.51.2.0', which is also in package ffmpeg SVN-r25943-1
    I can't uninstall this broken version and I can't get all the applications that had to be uninstalled back! What do I do?!

  2. #2
    Join Date
    Apr 2009
    Location
    Rawalpindi, Pakistan
    Beans
    5,666
    Distro
    Ubuntu Gnome Development Release

    Re: Seriously borked computer installing ffmpeg from svn

    Try cleaning your apt-get cache.

    Code:
    sudo apt-get clean

  3. #3
    Join Date
    Apr 2007
    Location
    New York
    Beans
    135
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Seriously borked computer installing ffmpeg from svn

    Phew, tried sudo dpkg -P --force-all ffmpeg, and it seems to have worked.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •