Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: mountall: disconnected from plymouth

  1. #1
    Join Date
    Jan 2007
    Beans
    341
    Distro
    Ubuntu 10.10 Maverick Meerkat

    mountall: disconnected from plymouth

    Several messages fly by, the screen flickers a few times, then I'm presented with this the message mountall: disconnected from plymouth.

    I've followed various threads that have similar errors. I've attempted the solutions in those threads, to no avail.

    After the above message is displayed I can't type at the keyboard to log in. I've managed that machine in the past from SSH so I tried to SSH into it. That allows me access to the box and it's how I tried those other thread's attempted solutions.

    Quote Originally Posted by dino99 View Post
    sudo apt-get update
    sudo apt-get install -f

    sudo dpkg --configure -a
    sudo dpkg-reconfigure jockey
    sudo dpkg-reconfigure plymouth
    sudo dpkg-reconfigure gdm
    Those were tried with no solution to the problem.

    I reinstalled the video drivers which had caused similar errors on several of my other Ubuntu boxes in the past.

    Of all the releases of Ubuntu, so far, this one has been the worst when it comes to upgrades.

    Suggestions?

  2. #2
    Join Date
    Oct 2010
    Beans
    1

    Re: mountall: disconnected from plymouth

    I had the same error, I logged in and then i typed sudo su and logged in as super user, immediately after that I was taken to the normal log in screen and it worked fine and am back in the system! So just log in as super user and the problem goes away.

  3. #3
    Join Date
    Jan 2007
    Beans
    341
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: mountall: disconnected from plymouth

    The problem is that I can only log in via SSH.

    The system worked prior to this update. I'd been using it for well over a year, maybe two.

    Edit:

    Just tried it with SSH. Didn't work. Didn't change anything.
    Last edited by jimbo99; October 22nd, 2010 at 11:51 PM.

  4. #4
    Join Date
    Oct 2010
    Beans
    17
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: mountall: disconnected from plymouth

    Quote Originally Posted by varun.kapoor View Post
    I had the same error, I logged in and then i typed sudo su and logged in as super user, immediately after that I was taken to the normal log in screen and it worked fine and am back in the system! So just log in as super user and the problem goes away.
    I had the same error after fooling around with mediatomb then apt-get upgrading. I can TTY in and su, but still the same error on my linux box. I have the latest stable Kubuntu.

    SOLVED:
    Mediatomb's log had expanded to fill my entire hd. Log deleted, problem solved. All of my future linux installs will have a separate var partition.
    Last edited by anypundit; November 3rd, 2010 at 07:41 AM. Reason: SOLVED

  5. #5
    Join Date
    Aug 2009
    Location
    United States
    Beans
    4,459
    Distro
    Ubuntu Development Release

    Re: mountall: disconnected from plymouth

    Do you all get a plymouth splash screen or does mountall hit before graphic drivers and fail to get your splash screen? If so make drivers hit before / mounts.
    This is a fix from launchpad. Will force graphic drivers to hit before mountall package.
    I have used for that purpose. If you feel problem is different and you get a splash then
    just save for reference. This is only to get plymouth to start and nothing else.

    Code:
    sudo -i
    Code:
    echo FRAMEBUFFER=y > /etc/initramfs-tools/conf.d/splash
    update-initramfs -u
    Last edited by garvinrick4; October 24th, 2010 at 09:35 PM.
    Remember hence where you come and pass it down.
    Ubuntu Forums member #899097 and Ubuntu Member:
    http://www.ubuntupocketguide.com/index_main.html
    Main Page -

  6. #6
    Join Date
    Jan 2007
    Beans
    341
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: mountall: disconnected from plymouth

    Quote Originally Posted by garvinrick4 View Post
    Do you all get a plymouth splash screen or does mountall hit before graphic drivers and fail to get your splash screen? If so make drivers hit before / mounts.
    This is a fix from launchpad. Will force graphic drivers to hit before mountall package.
    I have used for that purpose. If you feel problem is different and you get a splash then
    just save for reference. This is only to get plymouth to start and nothing else.

    Code:
    sudo -i
    Code:
    echo FRAMEBUFFER=y > /etc/initramfs-tools/conf.d/splash
    update-initramfs -u
    The real question is "WHAT IS PLYMOUTH" and why isn't it starting? This isn't isolated. This is major. I now have two computers inflicted with this problem.

    I cannot get into Ubuntu. No desktop. On one machine I can get into the terminal via SSH and the other from that computer. I can issue normal commands.

    No one here seems to have come up with a cogent solution. Why is this not working and why is it giving this problem and can't anyone trace the issue and tell us what the cause is?

    Before anyone goes further I think the PLYMOUTH issue is a non-starter. I think the issue has to do with the xorg.conf file. Starting with the failsafe version of the file the desktop is achievable. Once you install the video drivers getting to the gui desktop is not.
    Last edited by jimbo99; October 26th, 2010 at 12:50 AM.

  7. #7
    Join Date
    Jan 2007
    Beans
    341
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: mountall: disconnected from plymouth

    What I did to finally get both of my computers working was:

    1) When presented with the login prompt that I couldn't type at, press alt + ctrl + F2 to switch to the next terminal. I could then log in.

    2) Go into the /etc/X11 folder and rename the xorg.conf to some other file such as xorg.conf.jimbo.backup. Copy the xorg.conf.failsafe to xorg.conf.

    3) Issue the two commands above about initramfs and the framebuffer.

    4) Uninstall the nvidia driver by running sudo nvidia-installer --uninstall. Then reboot.

    5) When given the desktop go to the System>Administration>Additional Drivers and install the latest nvidia drivers through that. (I'm sure you can download and reinstall the latest drivers from nVidia's website, but no guarantees on that).

    6) Reboot.

    If you are using KDE as your DM then you may have to log into gnome first and rename your .kde folder (and possibly others), then log back out and change to the KDE DM and try again. (I have to revise this--after installing the downloaded nvidia drivers I was able to get to the kde desktop without modifying the KDE install by getting rid of the .kde folder).

    The other errors about PLYMOUTH and moutall seem to be simply status messages from the boot sequence attempt. They probably aren't error messages.

    I'm not sure you need to do the two commands regarding initramfs and framebuffer as explained above by another poster.

    Either way, this is nasty and all too common an occurrence to not have Canonical fix it promptly.

    In the second computer's case, I didn't get window title bars with buttons. After a while they showed up. Also, there were no additional drivers available for it using the System>Adminstration>Additional Drivers option, so I downloaded from nVidia's site the updated 260.19.xx drivers and installed them. Those brought me to a normal desktop, albeit gnome (when I use KDE normally).
    Last edited by jimbo99; October 26th, 2010 at 02:01 AM.

  8. #8
    Join Date
    May 2006
    Beans
    15

    Re: mountall: disconnected from plymouth

    Quote Originally Posted by jimbo99 View Post
    What I did to finally get both of my computers working was:

    1) When presented with the login prompt that I couldn't type at, press alt + ctrl + F2 to switch to the next terminal. I could then log in.

    2) Go into the /etc/X11 folder and rename the xorg.conf to some other file such as xorg.conf.jimbo.backup. Copy the xorg.conf.failsafe to xorg.conf.

    3) Issue the two commands above about initramfs and the framebuffer.

    4) Uninstall the nvidia driver by running sudo nvidia-installer --uninstall. Then reboot.

    5) When given the desktop go to the System>Administration>Additional Drivers and install the latest nvidia drivers through that. (I'm sure you can download and reinstall the latest drivers from nVidia's website, but no guarantees on that).

    6) Reboot.
    Thank you so much. It has been a lifesaver for me. After a Maverick update I wasn't able to login, and after the "mountall: disconnected from Plymouth" message the keyboard was not recognized (weird).

    Anyway, this is the right solution. I renamed the xorg.conf file from another disto I had installed, but the same can be accomplished from a LiveCD or LiveUSB,

    Cheers and thanks for the little solution. If you ever come to Madrid, I owe you a beer and a pincho de tortilla de patatas

  9. #9
    Join Date
    Oct 2008
    Beans
    9
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: mountall: disconnected from plymouth

    Hello,
    when I run sudo nvidia-installer --uninstall, I get the message that the command nvidia-installer does not exist. Perhaps I should be writing it differently?
    Also, in X11 I didn't find an xorg.conf.failsafe so I copied the new xorg.conf.backup back to xorg.conf .
    Any help with the nvidia-installer would be great (sorry for such a basic question).

  10. #10
    Join Date
    Dec 2008
    Beans
    5

    Re: mountall: disconnected from plymouth

    Quote Originally Posted by jimbo99 View Post
    What I did to finally get both of my computers working was:

    1) When presented with the login prompt that I couldn't type at, press alt + ctrl + F2 to switch to the next terminal. I could then log in.

    2) Go into the /etc/X11 folder and rename the xorg.conf to some other file such as xorg.conf.jimbo.backup. Copy the xorg.conf.failsafe to xorg.conf.

    3) Issue the two commands above about initramfs and the framebuffer.

    4) Uninstall the nvidia driver by running sudo nvidia-installer --uninstall. Then reboot.

    5) When given the desktop go to the System>Administration>Additional Drivers and install the latest nvidia drivers through that. (I'm sure you can download and reinstall the latest drivers from nVidia's website, but no guarantees on that).

    6) Reboot.

    If you are using KDE as your DM then you may have to log into gnome first and rename your .kde folder (and possibly others), then log back out and change to the KDE DM and try again. (I have to revise this--after installing the downloaded nvidia drivers I was able to get to the kde desktop without modifying the KDE install by getting rid of the .kde folder).

    The other errors about PLYMOUTH and moutall seem to be simply status messages from the boot sequence attempt. They probably aren't error messages.

    I'm not sure you need to do the two commands regarding initramfs and framebuffer as explained above by another poster.

    Either way, this is nasty and all too common an occurrence to not have Canonical fix it promptly.

    In the second computer's case, I didn't get window title bars with buttons. After a while they showed up. Also, there were no additional drivers available for it using the System>Adminstration>Additional Drivers option, so I downloaded from nVidia's site the updated 260.19.xx drivers and installed them. Those brought me to a normal desktop, albeit gnome (when I use KDE normally).
    This works!
    I was installing the 280.26 nvidia drivers from nvidia.com and it caused this issue.
    Thank you

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •