Results 1 to 8 of 8

Thread: How to hide icons etc in Gnome Desktop?

  1. #1
    Join Date
    Aug 2009
    Beans
    287

    How to hide icons etc in Gnome Desktop?

    Hi all.

    I want to hide objects, i.e. icons, files, etc from the desktop view in Gnome, just like it is by default with KDE. Why? because I use folderview screenlets, that work just like in KDE. It's just that I love how KDE looks, but I really hate KDE(4) itself.

    Any ideas?

  2. #2
    Join Date
    Feb 2006
    Location
    So.San Francisco
    Beans
    745

    Re: How to hide icons etc in Gnome Desktop?

    Open a terminal, type gconf-editor and hit enter.
    Then navigate to apps/nautilus/desktop. There you can uncheck what is currently residing on your desktop.



    darco
    Reason: no beans

  3. #3
    Join Date
    Aug 2009
    Beans
    287

    Re: How to hide icons etc in Gnome Desktop?

    I have already deleted the trash and other default icons.

    I'm talking about objects like files. I want the files to appear in the folder view of the desktop but no the desktop itself.

    I turned off 'show desktop' in gconf, but it has some side effects I don't like.

    thanks though.

  4. #4
    Join Date
    Apr 2005
    Location
    Finland/UK
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: How to hide icons etc in Gnome Desktop?

    Sorry, but the only way is to disable Nautilus from showing the desktop (like you already did). Nautilus doesn't have any option for just hiding the icons.

    Of course that means you'll loose both your wallpaper (you can use anther app to set a wallpaper) and the right-click menu on desktop.

    Apart from that the only option I can think of is simply not putting any files in the Desktop directory. Just use some other directory for your screenlet.

  5. #5
    Join Date
    Oct 2010
    Location
    Budapest, Hungary
    Beans
    8
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: How to hide icons etc in Gnome Desktop?

    I use Maverick (10.10)
    Today after a normal reboot, all the folders in the Home directory appeared on my desktop. None of the above mentioned things don't work, in the gconf-editor the above mentioned checkbox is not checked. Checking or unchecking that checkbox makes no difference, the folders are constantly on the desktop.

    I have no idea why they are there...
    Any idea is highly appreciated. Thanks in advance.

  6. #6
    Join Date
    Oct 2010
    Location
    India
    Beans
    432
    Distro
    Ubuntu Development Release

    Re: How to hide icons etc in Gnome Desktop?

    Quote Originally Posted by Janoka View Post
    I use Maverick (10.10)
    Today after a normal reboot, all the folders in the Home directory appeared on my desktop. None of the above mentioned things don't work, in the gconf-editor the above mentioned checkbox is not checked. Checking or unchecking that checkbox makes no difference, the folders are constantly on the desktop.

    I have no idea why they are there...
    Any idea is highly appreciated. Thanks in advance.
    i have the same problem since i upgraded from jaunty to lucid and now to maverick. i tried all the jugglery thats mentioned in the forum but no result !!! something must b wrong with nautilus ? i created another username and tried it there, everything is fine !!! wonder some small problem must b created which i m unable to identify.

  7. #7
    Join Date
    Oct 2010
    Location
    India
    Beans
    432
    Distro
    Ubuntu Development Release

    Re: How to hide icons etc in Gnome Desktop?

    i even deleted the .nautilus from my home directory, logged out and re-logged just to check if the new dot file thats created works fine, still the same problem persists !!!

    thanx in advance for help from forum members !!! m sure janoka will be happy too if this is resolved soon !

  8. #8
    Join Date
    Oct 2010
    Location
    India
    Beans
    432
    Distro
    Ubuntu Development Release

    Re: How to hide icons etc in Gnome Desktop?

    i m attaching my maverick desktop logged on to desktop edition (netbook edition desktop is not viewed so no issue, only hitch is the right flick menu thats disabled in netbook edition)
    Attached Images Attached Images

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •