Results 1 to 10 of 17

Thread: MenCoder, FFMPEG, VP7 codec troubles

Hybrid View

  1. #1
    Join Date
    Oct 2008
    Beans
    7

    Question MenCoder, FFMPEG, VP7 codec troubles

    Hello everybody.

    I've got a problem. On my web-server stores 250 Gb of videos encoded with codec VP7.

    Now I must:

    • Re-encode videos with xvid.
    • Take screenshots in GIF format from 10 frames.
    • Place watermark from transperent GIF


    Initially I wanna use FFMPEG, but when I install it I get error while encoding because he doesn't understand input codec. And also I know that getting screenshots is very slowly in FFMPEG (for screenshot at 30 minute it takes 52 seconds). So I decide to try Mplayer. But he is not support watermarks at all.

    AFAIR VP7 is part of Intel Indeo codecs which versions above 3.0 doesn't supported in any opensource project.

    Then I find rather interesting lines at http://www.mplayerhq.hu/design7/info.html
    # Intel Indeo3 (3.1, 3.2)
    # Intel Indeo 4.1 and 5.0 (using x86 DLL or XAnim codecs)
    Then when I install mplayer and try to use it I've got another error:

    root@Ubuntu-804-hardy-LTS-64-minimal:/www/pages/klipz.ru/1# mencoder test.avi -o test2.avi -of lavf -ovc xvid
    MEncoder 1.0rc2-4.2.3 (C) 2000-2007 MPlayer Team
    CPU: AMD Athlon(tm) 64 X2 Dual Core Processor 6000+ (Family: 15, Model: 67, Stepping: 3)
    CPUflags: Type: 15 MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 1
    Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE SSE2

    success: format: 0 data: 0x0 - 0x0
    Seek failed
    ============ Sorry, this file format is not recognized/supported =============
    === If this file is an AVI, ASF or MPEG stream, please contact the author! ===
    Cannot open demuxer.

    Exiting...
    What's wrong with it? (((

  2. #2
    Join Date
    Feb 2007
    Beans
    4,045
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: MenCoder, FFMPEG, VP7 codec troubles

    Have you installed the w32codecs package from the medibuntu repository?

  3. #3
    Join Date
    Oct 2008
    Beans
    7

    Re: MenCoder, FFMPEG, VP7 codec troubles

    Quote Originally Posted by geirha View Post
    Have you installed the w32codecs package from the medibuntu repository?
    Sorry, I'm very newbie
    I try to do it this way:
    root@Ubuntu-804-hardy-LTS-64-minimal:~# apt-get install w32codecs
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Package w32codecs is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    E: Package w32codecs has no installation candidate
    How I can change repository server on other from ssh?
    Before tuning server I already use Ubuntu as a Desktop but install everything with synaptic. Not manually

  4. #4
    Join Date
    Feb 2007
    Beans
    4,045
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: MenCoder, FFMPEG, VP7 codec troubles

    The medibuntu link I provided has instructions on how to add the medibuntu repository (Repository Howto). After it is added, running apt-get install w32codecs should work as expected.

  5. #5
    Join Date
    Oct 2008
    Beans
    7

    Re: MenCoder, FFMPEG, VP7 codec troubles

    Quote Originally Posted by geirha View Post
    The medibuntu link I provided has instructions on how to add the medibuntu repository (Repository Howto). After it is added, running apt-get install w32codecs should work as expected.
    Thanks! I try to follow manual at link you provided but now I get same error.

    root@Ubuntu-804-hardy-LTS-64-minimal:~# apt-get install w32codecs
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Package w32codecs is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    E: Package w32codecs has no installation candidate
    BTW how can I get list of packages by PCRE (for example "/w32codesc(.*)/i"?

  6. #6
    Join Date
    Feb 2007
    Beans
    4,045
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: MenCoder, FFMPEG, VP7 codec troubles

    Quote Originally Posted by iSlayter View Post
    Thanks! I try to follow manual at link you provided but now I get same error.
    You need to run
    Code:
    sudo apt-get update
    # or
    sudo aptitude update
    To download the package lists first. Forgot to mention that.
    Quote Originally Posted by iSlayter View Post
    BTW how can I get list of packages by PCRE (for example "/w32codesc(.*)/i"?
    aptitude search accepts regular expressions

    Code:
    aptitude search '^w[0-9]+codecs$'
    This is documented in /usr/share/doc/aptitude/

  7. #7
    Join Date
    Oct 2008
    Location
    Seattle, WA
    Beans
    6
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: MenCoder, FFMPEG, VP7 codec troubles

    My guess is that you have not installed the required dll as it lists. This will likely need to be run under wine as well to have use of the dll or run on ms machine. Might check the mplayerhq.hu faq, I seen a hint about this there I think.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •