Results 1 to 10 of 12

Thread: [SOLVED] GNOME PPP Check permissions

Hybrid View

  1. #1
    Join Date
    Jun 2007
    Location
    Canada (West Coast)
    Beans
    Hidden!
    Distro
    Kubuntu 13.04 Raring Ringtail

    [SOLVED] GNOME PPP Check permissions

    Trying to set up a laptop to use a USRobotics Model 5637 USB modem so a friend can use a dial-up Internet connection.

    This person needs a graphical user interface so I thought that GNOME PPP would be good. However I have been trying to get it to work on my laptop and when it tries to connect I get the following error:

    Carrier detected. Starting PPP immediately
    Unable to run /usr/sbin/pppd
    Check permissions, or specify a "PPPD Path" option in wvdial.conf

    Below is the content of wvdial.conf
    [Dialer Defaults]
    New PPPD = yes
    Stupid Mode = yes
    Modem Thpe = Analog Modem
    ISDN = 0
    Auto DNS = 1
    Auto Reconnect = 0
    Modem = /dev/ttyACM0
    Baud = 230400
    Initl = ATZ4

    Phone = 250 388 5747
    Username = {name}
    Password = {password}

    Here is what the specs on on /usr/sbin/pppd :
    Type is: executable,
    permissions are: -rwxrwxr--
    Owner:Group is: root:30 That looks odd to me but I am still pretty green with Ubuntu.

    Can anyone suggest what I must change, and how to get this machine to connect to the Internet via dial-up using GNOME PPP or other graphical interface?
    Volunteer installer and supporter of people who want to explore the Linux alternative.

  2. #2
    Join Date
    Oct 2008
    Location
    Germany
    Beans
    1
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: GNOME PPP Check permissions

    Hi,
    I was facing the same problem. Here is the solution (at least it solved the problem for me):
    Open a terminal window and enter the following commands:
    sudo chown root:dip /usr/sbin/pppd
    sudo chmod 4754 /usr/sbin/pppd
    sudo chmod 777 /etc/ppp/pap-secrets
    sudo chmod 777 /etc/ppp/peers

    That should grant the required permissions and enable the connection to the internet.

    Hope it helps.

  3. #3
    Join Date
    Jun 2007
    Location
    Canada (West Coast)
    Beans
    Hidden!
    Distro
    Kubuntu 13.04 Raring Ringtail

    Re: GNOME PPP Check permissions

    For the benefit of those who were following this thread and providing help, I have returned from my sojourn to install an Ubuntu system for an old friend who lives 1000 miles away and who only has access to a dial-up Internet connection.

    The installation went beautifully! thanks to your help. I was able to install the Gnome-PPP dialer but I had to change some settings in "wvdial.conf as well as incorporate other suggestions before it would work.

    My friend is happy and I am back home and can provide support to him while he learns the finer points of using Ubuntu. The emails from him are a little odd because he has never ever used even a typewriter, but he is enjoying the experience and is really learning fast. Before I left, he had mastered sending and receiving emails, browsing the Internet and had even made a purchase off the Internet.

    His family and neighbors are astounded, particularly one academic neighbor who warned him NOT to install Linux because "nobody around will be able to help you when you have trouble". I wonder what she is thinking now?
    My friend's daughters-in-law have even become curious about Linux and I left a desktop CD with them to try.

    A big "Thank You!" to travm, ModelM, and _duncan for the help you provided in making Ubuntu available to an ordinary person.

    Mac
    Volunteer installer and supporter of people who want to explore the Linux alternative.

  4. #4
    Join Date
    Dec 2008
    Beans
    3

    Re: GNOME PPP Check permissions

    Thanks for the post pacz! I've been trying to figure this out for quite some time. It works great and it seems as though it sped up my connection too!

  5. #5
    Join Date
    Sep 2007
    Location
    Over thar
    Beans
    310
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: [SOLVED] GNOME PPP Check permissions

    Thanks for the fix pacz999!

    I only needed the first two lines to get my Samsung M610 cell phone tethered through gnome-ppp as a normal user:

    Code:
    sudo chown root:dip /usr/sbin/pppd
    sudo chmod 4754 /usr/sbin/pppd

  6. #6
    Join Date
    Jul 2007
    Beans
    96

    Re: [SOLVED] GNOME PPP Check permissions

    didn't work for me
    Why doesn't basic stuff just work and why is it not in the basic install?
    Ubuntu is the best os I've ever used but, why does it have to be so incomplete and unfinished? I've been experimenting with a lot of different distributions, and they all have problems. Too techi, most people know nothing about boot loaders and grubs and networking ISP's, DNS, Mac addresses - where is that? -Appleville? Some won't load at all.
    These dialer issues really are a turn-off for an average rural user that has no access to high speed internet. How can you download gnome ppp dialer if you have no dialer to get on the internet in the first place?
    Smart people are really dumb sometimes.
    And wireless, what a pain, I guess you have to be a computer engineer to figure that out. So far every computer I try sees the wireless network but will not conect to it.

  7. #7
    Join Date
    Sep 2007
    Location
    Over thar
    Beans
    310
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: [SOLVED] GNOME PPP Check permissions

    Quote Originally Posted by bth73 View Post
    didn't work for me
    Why doesn't basic stuff just work and why is it not in the basic install?
    Ubuntu is the best os I've ever used but, why does it have to be so incomplete and unfinished? I've been experimenting with a lot of different distributions, and they all have problems. Too techi, most people know nothing about boot loaders and grubs and networking ISP's, DNS, Mac addresses - where is that? -Appleville? Some won't load at all.
    These dialer issues really are a turn-off for an average rural user that has no access to high speed internet. How can you download gnome ppp dialer if you have no dialer to get on the internet in the first place?
    Smart people are really dumb sometimes.
    And wireless, what a pain, I guess you have to be a computer engineer to figure that out. So far every computer I try sees the wireless network but will not conect to it.
    Probably, if you were actually writing the code for Gnome PPP / networking and trying to get it to work with all the different modems (dial-up, cell phone modems etc) out there, you'd find out it is not so simple.

    Rather than complaining, why not just state the modem you are using, what you did to try and get it working, and what the error message is. Somebody might be able to help you in that case.

    In my experience, wireless has in most cases just worked out of the box on Ubuntu and several other distros, even with new wireless cards like the Intel 5300 and also cards from manufacturers that don't provide open source drivers like Broadcom.
    Last edited by undoIT; January 31st, 2009 at 06:04 PM.

  8. #8
    Join Date
    Feb 2010
    Beans
    18

    Post Re: [SOLVED] GNOME PPP Check permissions

    Quote Originally Posted by MacDuff View Post
    Trying to set up a laptop to use a USRobotics Model 5637 USB modem so a friend can use a dial-up Internet connection.

    This person needs a graphical user interface so I thought that GNOME PPP would be good. However I have been trying to get it to work on my laptop and when it tries to connect I get the following error:

    Carrier detected. Starting PPP immediately
    Unable to run /usr/sbin/pppd
    Check permissions, or specify a "PPPD Path" option in wvdial.conf

    Below is the content of wvdial.conf
    [Dialer Defaults]
    New PPPD = yes
    Stupid Mode = yes
    Modem Thpe = Analog Modem
    ISDN = 0
    Auto DNS = 1
    Auto Reconnect = 0
    Modem = /dev/ttyACM0
    Baud = 230400
    Initl = ATZ4

    Phone = 250 388 5747
    Username = {name}
    Password = {password}

    Here is what the specs on on /usr/sbin/pppd :
    Type is: executable,
    permissions are: -rwxrwxr--
    Owner:Group is: root:30 That looks odd to me but I am still pretty green with Ubuntu.

    Can anyone suggest what I must change, and how to get this machine to connect to the Internet via dial-up using GNOME PPP or other graphical interface?
    Just in case anyone else is browsing this thread, there's another way to solve this problem. I tried granting permission using the terminal but it didn't work, so here's how I did it:

    Open terminal.
    Open nautilus by typing "sudo nautilus".
    Enter password when prompted.
    When the file browser opens, go to the folder usr, then to folder sbin,where you will find the executable program pppd.
    Right click on ppd, go to properties, then go to permissions tab under properties.
    There, you will find an option for allowing the program to be run as an executable (I've forgotten the exact words). There's a check box adjacent to it. If there is a minus (-) sign in this box, click it to change it to a tick sign. Now permissions are ok and you should be able to use gnomeppp which executes pppd without a problem.
    Last edited by hst19; February 20th, 2010 at 09:35 AM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •