Results 1 to 10 of 12

Thread: need help configuring torK

Hybrid View

  1. #1
    Join Date
    Aug 2007
    Beans
    48

    need help configuring torK

    I am trying to configure torK on my x386 computer running Ubuntu 8.04 and I am running into some problems. Could you please point me towards the right solution?

    I installed torK, tor and privoxy without any problems.

    I used the torK wizard to configure to to run as a client.
    Code:
    I configured torK to lauch tor when needed (tor is not started at bootup)
    
    When I try to lauch torK from the "press play to get started"  I get this message:
    
    TorK couldn't start your Privacy Proxy!
    Message: Nothing.
    Reason: This may be because you have configured it to launch at system startup. If that is the case, and you have reason to believe it is configured to listen to Tor, then just click 'No' and take a look at the 'Konqueror' settings in the configuration dialog.
    Would you like TorK to try restarting it again?
    Then I choose 'yes' and I get:

    Code:
    Tor Couldn't Bind to One of the Addresses/Ports you configured!
    Message: May 19 15:52:14.256 [warn] Could not bind to 127.0.0.1:9050: Address already in use. Is Tor already running?
    Reason: Tor is probably already running. If you like, TorK can connect to the already-running instance of Tor and manage that for you instead. (You will have to open the configuration dialog and re-apply any settings you wished to use.)
    Would you like to do this now?

    and when I choose 'yet' I get:
    Code:
    TorK has passed an invalid configuration file to Tor!
    Message: May 19 15:52:14.256 [warn] Failed to parse/validate config: Failed to bind one of the listener ports.
    This means: Please report this using 'Help->Report Bug' in the menu. Try to provide as much detail as possible. Thanks!
    What am I doing wrong? How do I manually start tor and privoxy and have torK use them?

    I know that it is not my hardware or network because I ran torK off a live-CD and everything worked perfectly.

    Many thanks in advance for any pointers!

  2. #2
    Join Date
    Nov 2007
    Location
    Ohio
    Beans
    12
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: need help configuring torK

    i'm having the same problem.

  3. #3
    Join Date
    Mar 2007
    Beans
    42
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: need help configuring torK

    anyone come up with an answer to this?

  4. #4
    Join Date
    Nov 2005
    Location
    Karachi - Pakistan
    Beans
    1

    Re: need help configuring torK

    Same problem.

  5. #5
    Join Date
    Apr 2008
    Location
    /jordan.d
    Beans
    137

    Re: need help configuring torK

    same problem here..
    am behind a proxy with a smart filter feature..something like web sense, which prevents me from reaching websites like youtube.com and certain pages in the sourceforge.com domain...
    can these applications help me out in this ?? if so..am having the very same problem as mentioned above..
    any suggestions ??
    Last edited by mkrahmeh; September 14th, 2008 at 08:14 PM.
    M Abu Rahmeh
    ‘—so long as I get somewhere,’ Alice added as an explanation.
    ‘Oh, you’re sure to do that,’ said the Cat, ‘if you only walk long enough.’

  6. #6
    Join Date
    Jun 2008
    Location
    UK
    Beans
    25
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: need help configuring torK

    Got the same on my 8.04.
    Why no one can see the bug in it? Do so little people use TorK?

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •