Results 1 to 3 of 3

Thread: Can't get above 480p on HDTV (7.10)

Hybrid View

  1. #1
    Join Date
    Jun 2005
    Location
    Plymouth, UK
    Beans
    20

    Can't get above 480p on HDTV (7.10)

    Hi. I've got a HDTV which I can't seem to get to run at a decent resolution. No matter what I do, I can never seem to get it to run at anything other than 720x480, despite my Windows partition running fine at 720p (1216x684).

    I'm using a Goodmans GTVL19W17HD and an Nvidia GeForce 6200, with the two connected via a DVI-HDMI lead. Nvidia-settings doesn't offer me a resolution above 480p, and I've messed about with xorg.conf so much with no success. Here's my current layout:

    Code:
     nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig:  version 1.0  (buildmeister@builder3)  Mon Apr 16 20:37:13 PDT 2007
    
    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings:  version 1.0  (buildmeister@builder3)  Mon Apr 16 20:38:05 PDT 2007
    
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0" 0 0
        Screen      1  "Screen1" 1024 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
    EndSection
    
    Section "Files"
        RgbPath         "/usr/lib/X11/rgb"
    EndSection
    
    Section "Module"
        Load           "dbe"
        Load           "extmod"
        Load           "type1"
        Load           "freetype"
        Load           "glx"
    EndSection
    
    Section "ServerFlags"
        Option         "Xinerama" "0"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
    
        # generated from default                  
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection
    
    Section "Monitor"
    
        # HorizSync source: edid, VertRefresh source: edid
        Identifier     "Television"
        ModelName      "Proview GTVL19W17HD"
        Option         "IgnoreEDID"
        Modeline "1216x684@60" 66.05 1216 1248 1496 1528 684 698 705 719
        HorizSync      45.43
        VertRefresh     60.0
    EndSection
    
    Section "Monitor"
    
        # HorizSync source: edid, VertRefresh source: edid
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "Proview GTVL19W17HD"
        HorizSync       31.0 - 60.0
        VertRefresh     60.0 - 75.0
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "Videocard0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce 6200"
        BusID          "PCI:1:0:0"
           Option       "RenderAccel" "true"
           Option       "AllowGLXWithComposite" "true"
           Option       "ConnectedMonitor" "DFP"
        Screen          0
    EndSection
    
    Section "Device"
        Identifier     "Videocard1"
        Driver         "nvidia"
       VendorName     "NVIDIA Corporation"
        BoardName      "GeForce 6200"
        BusID          "PCI:1:0:0"
           Option       "RenderAccel" "true"
           Option       "AllowGLXWithComposite" "true"
           Option       "ConnectedMonitor" "DFP"
        Screen          1
    EndSection
    
    Section "Screen"
        Identifier     "Screen1"
        Device         "Videocard0"
        Monitor        "Television"
        DefaultDepth    24
        Option         "AddARGBGLXVisuals" "True"
        SubSection     "Display"
            Depth       24
            Modes      "1216x684@60"
       EndSubSection
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Videocard1"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "metamodes" "CRT: 1024x768_60 +0+0"
        Option         "AddARGBGLXVisuals" "True"
        SubSection     "Display"
            Depth       24
            Modes      "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
    EndSection

    I'm currenty running this on twinview with the VGA port on my HDTV (though this is limited to 1024x768) but I would like just to use the DVI port once I can get this resolution problem sorted. Thanks.

  2. #2
    Join Date
    Jun 2005
    Location
    Plymouth, UK
    Beans
    20

    Re: Can't get above 480p on HDTV (7.10)

    Sorry to bump, but has anyone got any advice at all? I've looked all over the place but to no avail.

  3. #3
    Join Date
    Jun 2005
    Location
    Plymouth, UK
    Beans
    20

    Re: Can't get above 480p on HDTV (7.10)

    Problem was solved by upgrading to 8.04 and using nvidia-glx-new. I've got Overscan problems now, but at least I have a decent resolution.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •