Page 1 of 2 12 LastLast
Results 1 to 10 of 22

Thread: Wireless no longer works after upgrading to Hardy Heron

Hybrid View

  1. #1
    Join Date
    Apr 2008
    Location
    Montreal
    Beans
    6
    Distro
    Hardy Heron (Ubuntu Development)

    Angry Wireless no longer works after upgrading to Hardy Heron

    I upgraded from Gutsy Gibbon 7.10 to Hardy Heron 8.04 LTS last night, using the update manager in Gutsy Gibbon, but after rebooting my wireless card no longer works. I have a D-link dwl-510 wireless card. It still shows up in the Device Manager, but I have nothing showing wireless connections on the upper right panel. What can I do to fix this? Have I missed something obvious? I am a new user of both Gutsy Gibbon and Hardy Heron.

    Should I install NDISWrapper and use the windows driver that came with my d-link dwl-510 card as suggested here?

    https://help.ubuntu.com/8.04/interne...iswrapper.html

    How can I do this when I can't even get online to download the ndisgtk package? Do I have to burn a Hardy Heron istallation CD and get it from there? I was hoping to avoid having to do this.
    Last edited by TomThePhotographer; May 3rd, 2008 at 01:40 AM.

  2. #2
    Join Date
    Apr 2008
    Beans
    16

    Re: Wireless no longer works after upgrading to Hardy Heron

    Did you upgrade wirelessly? Not always, but sometimes wireless gets bumped during the reconfiguration, leaving you without the HAL/backport wireless drivers. Plug into ethernet, wait a few. If the update doesnt start on its own, do it manually.
    Last edited by c007c; May 3rd, 2008 at 01:45 AM.

  3. #3
    Join Date
    Apr 2008
    Location
    Montreal
    Beans
    6
    Distro
    Hardy Heron (Ubuntu Development)

    Re: Wireless no longer works after upgrading to Hardy Heron

    Yes, i upgraded wirelessly. Plug into the ethernet? I don't have any way to plug this old Pentium III direcly into my router, if that's what you mean. I guess I would have to install an ethernet card. I was hoping to avoid having to do that, too. How about just going backwards and re-installing Gutsy Gibbon? Would that solve my problem?

  4. #4
    Join Date
    Apr 2008
    Location
    Montreal
    Beans
    6
    Distro
    Hardy Heron (Ubuntu Development)

    Re: Wireless no longer works after upgrading to Hardy Heron

    When I originally installed Gutsy Gibbon, my Wireless card was recognized, no problem, it's only with the update to Hardy Heron that I can't use my wireless card.

  5. #5
    Join Date
    Apr 2008
    Location
    Montreal
    Beans
    6
    Distro
    Hardy Heron (Ubuntu Development)

    Re: Wireless no longer works after upgrading to Hardy Heron

    I don't have any way of connecting an ethernet cable to my ubuntu installed computer. Couldn't I just do a complete re-installation of Gutsy Gibbon? ( a step backwards, it seems)

  6. #6
    Join Date
    Apr 2008
    Location
    Montreal
    Beans
    6
    Distro
    Hardy Heron (Ubuntu Development)

    Re: Wireless no longer works after upgrading to Hardy Heron

    This page seems to suggest a way of installing NDSWrapper without an internet connection...

    http://ubuntuforums.org/showthread.php?t=564419

    Install "ndiswrapper" package with working internet connection (Ethernet):

    Quote:
    sudo apt-get install ndiswrapper-common ndiswrapper-utils-1.9

    Install "ndiswrapper" package without working internet connection (alternatively, install it via Synaptic/Adept):

    Quote:
    sudo apt-cdrom add
    sudo apt-get update
    sudo apt-get install ndiswrapper-common ndiswrapper-utils-1.9

  7. #7
    Join Date
    Apr 2008
    Beans
    16

    Re: Wireless no longer works after upgrading to Hardy Heron

    Quote Originally Posted by TomThePhotographer View Post
    Yes, i upgraded wirelessly. Plug into the ethernet? I don't have any way to plug this old Pentium III direcly into my router, if that's what you mean. I guess I would have to install an ethernet card. I was hoping to avoid having to do that, too. How about just going backwards and re-installing Gutsy Gibbon? Would that solve my problem?
    If thats how you were successful originally, yes. Then give the upgrade a second try. Sometimes it works. But before you do, check and see if the linux-restricted-modules and common 2.6.24 are loaded. try installing them
    Last edited by c007c; May 3rd, 2008 at 01:59 AM.

  8. #8
    Join Date
    Apr 2008
    Location
    Montreal
    Beans
    6
    Distro
    Hardy Heron (Ubuntu Development)

    Re: Wireless no longer works after upgrading to Hardy Heron

    Quote Originally Posted by c007c View Post
    Check and see if the linux-restricted-modules and common 2.6.24 are loaded. try installing them
    How do I do this?

  9. #9
    Join Date
    Apr 2008
    Beans
    16

    Re: Wireless no longer works after upgrading to Hardy Heron

    System--->Administration--->Synaptic Package Manager. Then perform a search for "restricted". Mark for installation, apply. I'm hoping the package was downloaded, but not installed. or possibly you will see the former versions under installed or obsolete. they might get you by till you upgrade them
    Last edited by c007c; May 3rd, 2008 at 02:14 AM.

  10. #10
    Join Date
    May 2008
    Beans
    10

    Re: Wireless no longer works after upgrading to Hardy Heron

    Up front, I am the noobest of noobs regarding Linux, but I really like Hardy, and am using wubi to make the transition off of windows. I'm really liking it so far. I did get wireless working for my Atheros card, however it is a real pain in the rear, and I have tried all the remedies I have found here. The following is the only way I can get wireless access on my laptop.

    System->Administration->Network-> After you unlock, disable the enable roaming checkbox. Then select the wireless network you desire, and enter the appropriate information. It should start reconfiguring at this point. Do not hit close, but wait for it to reconfigure. Once that is complete,close, and you should be able to go to network tools and under the ath0 adapter you should have an IP address (provided you use DHCP). If you do, then wireless should be working. The problem is reenabling after a reboot. After a reboot, you will need to do the same above, except this time you need to enable roaming mode. Once this is done, close. Then go back in and repeat the steps above. Trust me, this is a good solution after having tried everything else and failing. If anyone knows a better way, I am all ears, but I'm typing this on my wireless network from my laptop using the steps above. Good luck.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •