Results 1 to 6 of 6

Thread: Ubuntu 8.04 Beta fixes laptop earphone problem

Hybrid View

  1. #1
    Join Date
    Jun 2007
    Location
    GA, USA
    Beans
    72
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Ubuntu 8.04 Beta fixes laptop earphone problem

    Alrighty, so I had bought a Toshiba laptop a few months back and was dissapointed when I plugged in my earphones and sound came from both the earphones and the regular speakers.

    I was using Feisty with Kubuntu. I knew it wasn't the jack as it worked under Windows just fine!

    Since the 8.04 Beta upgrade, using Gnome I might add, it works without a hitch. Haven't tried with KDE just yet, but I am extremely happy as this was a near deal breaker for me and I almost returned the laptop!

    I'm wondering if this has to do with Pulse Audio?

    Thought I'd share the good news. Now if only I can get Compiz Fusion running on it's ATI card...

  2. #2
    Join Date
    Jun 2007
    Location
    GA, USA
    Beans
    72
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Ubuntu 8.04 Beta fixes laptop earphone problem

    uh, that's meant to be Gutsy, not Feisty!

  3. #3
    Join Date
    Jul 2006
    Location
    Snellville, Ga
    Beans
    141
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Ubuntu 8.04 Beta fixes laptop earphone problem

    I know that on the 8.04 beta, the ATI driver on Ubuntu works with Compiz Fusion if you use the fgrlx driver provided via the Hardware Manager.
    LoCo About Ubuntu! - jonreagan.wordpress.com

    Vote for the Ubuntu Developer Network!!! - http://brainstorm.ubuntu.com/idea/18100/

  4. #4
    Join Date
    Jun 2007
    Location
    GA, USA
    Beans
    72
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Ubuntu 8.04 Beta fixes laptop earphone problem

    Quote Originally Posted by JReagan1990 View Post
    I know that on the 8.04 beta, the ATI driver on Ubuntu works with Compiz Fusion if you use the fgrlx driver provided via the Hardware Manager.
    After I posted I decided to dig a little deeper on that; found that I also had to install xserver-xgl. This worked, but there was a crash at every login - gnome-settings-manager or something along those lines.

    Now this was an upgrade, so I wiped everything and did a fresh install but have not, as of yet, experimented any further with it. One of my children broke the USB network card! Just snapped it... yup, he snapped it! So I cannot download anything until I get that sorted out.

    Still, 8.04 is noticing the internal Atheros card in the "Restricted Devices", but I haven't seen it actually show up anywhere usable? *scratches head a little*.

    JC

  5. #5
    Join Date
    Jun 2007
    Location
    GA, USA
    Beans
    72
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Ubuntu 8.04 Beta fixes laptop earphone problem

    Okay, so I decided to go ahead and do a fresh install.

    I attempted to get the Atheros wireless to work using a madwifi guide that seemed to work for most people. I opted for ndiswrapper when that failed. I had to disable the HAL and Atheros support from the Hardware Drivers utility.

    Needless to say, it now works beautifully! In fact, it seems to be faster and gets better connections than the external USB Belkin I had.

    After getting that to work, I enabled the restricted ATI driver and rebooted to find that Compiz was working without doing anything. Only slight nag I have is that it did not include the compizconfig-settings-manager automatically, but a quick install from Synaptic solved that.

    I will post the URL for the Atheros driver when I get home tonight for those who may find this useful or having a similar problem.

  6. #6
    Join Date
    Jun 2007
    Location
    GA, USA
    Beans
    72
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Ubuntu 8.04 Beta fixes laptop earphone problem

    [Click Me] for the forum entry where I was able to find a usable driver for the internal Atheros card.

    Now an update on the compiz. I discovered with Compiz enabled, I get a flicker when attempting to play games like "lincity-ng" and on screen savers. I attempted to install xserver-xgl, which seems to get rid of the flicker, but then causes a crash upon login.

    Removing it gets rid of the crash. I read somewhere that it was a problem with the ATI driver (or is it?), so I'm hoping for a fix soon.

    Anyway, glad to have everything working, even with a slight hitch. At least I can shut it off without having to restart to play a game or two. Still the screen saver would be nice if it didn't flicker all the time.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •