Page 1 of 3 123 LastLast
Results 1 to 10 of 25

Thread: FarCry with WINE won't work

Hybrid View

  1. #1
    Join Date
    Nov 2007
    Location
    Slovenia
    Beans
    42
    Distro
    Ubuntu 8.04 Hardy Heron

    Unhappy FarCry with WINE won't work

    Hello,
    I got Ubuntu 7.10 and WINE 0.9.49. I got FarCry 5CD set and because I got error that CD couldn't be unmounted because it's in use, I used Loki installer, but since I was suspecting that something was wrong with the install, I copied files from Windows.After that there were few DLLs missing, which I installed, and now when I try to start the game, i get error 'CrySystem.dll Loading Failed: Module not found' . I got that .dll file, also on FarCry forums someone complained he got same error however it's associated with NVidia driver , but I got ATI Radeon 9550-RV350. I'm currently using open source driver, but FGLRX in ubuntu's repos doesn't work either. Any solution ?

  2. #2
    Join Date
    Oct 2005
    Location
    U.S.A.
    Beans
    4,164
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: FarCry with WINE won't work

    Did you compile 0.9.49 yourself? The DEB package isn't availalbe yet. What errors are output to the terminal when you run the game? How are you running the game (exact commands used)?

    Linux User #355330 | Ubuntu User #15618 | Last.FM

  3. #3
    Join Date
    May 2006
    Beans
    374
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: FarCry with WINE won't work

    Quote Originally Posted by cogadh View Post
    Did you compile 0.9.49 yourself? The DEB package isn't availalbe yet.
    Yes, it is.

    Just now, on my computer:
    Code:
       >  apt-cache showpkg wine
    Package: wine
    Versions: 
    0.9.49~winehq0~ubuntu~7.10-1 (/var/lib/apt/lists/wine.budgetdedicated.com_apt_dists_gutsy_main_binary-amd64_Packages) (/var/lib/dpkg/status)
     Description Language: 
                     File: /var/lib/apt/lists/wine.budgetdedicated.com_apt_dists_gutsy_main_binary-amd64_Packages
                      MD5: 41c511512dffd5fac91c839619c075b8

  4. #4
    Join Date
    Nov 2007
    Location
    Slovenia
    Beans
    42
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: FarCry with WINE won't work

    No, I had WINE installed previously and I updated it today with Update Manager.I run the Farcry.exe on the CD. There are no errors in terminal, just graphical error. Here is my terminal output :
    boris@boris-desktop:~$ cd /media/cdrom0
    boris@boris-desktop:/media/cdrom0$ wine FarCry.exe (after that FarCry pic shows up and I get the error)
    boris@boris-desktop:/media/cdrom0$

  5. #5
    Join Date
    Nov 2007
    Location
    Slovenia
    Beans
    42
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: FarCry with WINE won't work

    No one knows the solution ?

  6. #6
    Join Date
    May 2006
    Beans
    374
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: FarCry with WINE won't work

    Are you sure you have hardware 3d acceleration?

    What's the result of

    glxinfo | grep render

    ?

  7. #7
    Join Date
    Aug 2006
    Beans
    65

    Re: FarCry with WINE won't work

    Dont copy the files from windows would be my guess. You probably dont have the registry entries.

  8. #8
    Join Date
    Nov 2007
    Location
    Slovenia
    Beans
    42
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: FarCry with WINE won't work

    aoanly : result of grep | render:

    direct rendering: Yes
    OpenGL renderer string: Mesa DRI R300 20060815 AGP 8x x86/MMX/SSE2 TCL

    I got open source ATI driver which isn't yet complete but I tried with FGLRX as well and it doesn't work.

    jimminy_kriket: so I should use Loki installer's files ? And where do I have to put the files ? In WINE's C drive like C:/Program Files/Ubisoft/Crytek/FarCry/ ? I don't know where FarCry's CD will look for files after I start FarCry.

  9. #9
    Join Date
    Nov 2007
    Location
    Slovenia
    Beans
    42
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: FarCry with WINE won't work

    Please help me !

  10. #10
    Join Date
    May 2006
    Beans
    374
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: FarCry with WINE won't work

    I'm a bit worried about your renderer being something MESA - I'm not an expert on the opensource ATI driver, but usually that suggests that you're not actually getting proper hardware acceleration.

    What do you get with the fglrx driver?

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •