Page 1 of 3 123 LastLast
Results 1 to 10 of 27

Thread: Unreal Tournament GOTY sound quality issues

Hybrid View

  1. #1
    Join Date
    Apr 2005
    Beans
    432
    Distro
    Ubuntu

    Unreal Tournament GOTY sound quality issues

    I've got UT99 GOTY up and running, but the sound is horrible. It pops, stutters, and skips. I have sound working fine in Open Arena Quake 3, so something is up with UT. I wonder if it has something to do with OpenAL sound.

    Here's my soundcard:

    Code:
     Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
    I am running ALSA 1.0.14rc1.
    Last edited by NTolerance; January 2nd, 2007 at 08:15 AM.

  2. #2
    Join Date
    Aug 2006
    Beans
    Hidden!

    Re: Unreal Tournament GOTY sound quality issues

    Try installing "alsa-oss" and run UT GOTY like this: aoss ./ut

  3. #3
    Join Date
    Apr 2005
    Beans
    432
    Distro
    Ubuntu

    Re: Unreal Tournament GOTY sound quality issues

    Quote Originally Posted by neoclaw View Post
    Try installing "alsa-oss" and run UT GOTY like this: aoss ./ut
    Tried that, but it gave me garbled audio. The executable I'm running is ut-bin. Is that correct?

  4. #4
    Join Date
    Dec 2004
    Beans
    744
    Distro
    Edgy Eft Testing

    Re: Unreal Tournament GOTY sound quality issues

    I'm curious about this as well. I tried to install Rune on Linux and it did the same thing, and it's based on the exact same engine as well.

    Leech
    Wah! Wah! Life was more entertaining when I had 64KB of RAM in my computer.
    Neverwinter Nights Platinum HowTo

  5. #5
    Join Date
    Jun 2006
    Location
    South Africa
    Beans
    635
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Unreal Tournament GOTY sound quality issues

    I have the same issue and almost the same audio controller

    Code:
    0000:00:1b.0 0403: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 03)
    I've been trying to fix this for some time now, and I've been unsucessful. I've tried recompiling ALSA and even replaced some libraries.

    I had the same issue with Neverwinter Nights though, and the solution for that was to copy the SDL / OpenAL libraries from /usr/lib over the libraries in the NWN directory. Maybe this can solve the UT issue?
    Intel 3.2Ghz Prescott | 1024MB DDR2 533Mhz | Intel GEV915 Motherboard | GeForce 8600GT
    Registered Linux User #422029
    Name the next release Dodgy Duck!

  6. #6
    Join Date
    Apr 2005
    Beans
    432
    Distro
    Ubuntu

    Re: Unreal Tournament GOTY sound quality issues

    Quote Originally Posted by diepruis View Post
    I have the same issue and almost the same audio controller

    Code:
    0000:00:1b.0 0403: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 03)
    I've been trying to fix this for some time now, and I've been unsucessful. I've tried recompiling ALSA and even replaced some libraries.

    I had the same issue with Neverwinter Nights though, and the solution for that was to copy the SDL / OpenAL libraries from /usr/lib over the libraries in the NWN directory. Maybe this can solve the UT issue?
    I've updated the SDL lib to the latest version 1.2 used by UT2004. This makes no difference. I tried copying the stock Ubuntu OpenAL lib from the /usr/lib folder to the UT folder as well as openal.so from UT2004, but either of these will cause the game not to run.

    Supposedly there is a way to compile the latest OpenAL lib from here http://www.openal.org/, but I don't end up with a .so file when I try to compile it.
    Last edited by NTolerance; January 3rd, 2007 at 09:24 PM.

  7. #7
    Join Date
    Apr 2005
    Beans
    432
    Distro
    Ubuntu

    Re: Unreal Tournament GOTY sound quality issues

    I finally found my compiled libopenal.so file. It was hidden in the src/.lib directory. Unfortunately it causes UT not to start.

    Are you guys using the stock Edgy ALSA drivers or what? I read somewhere that development releases of ALSA can cause problems with OpenAL.

  8. #8
    Join Date
    Apr 2006
    Location
    Edinburgh UK
    Beans
    40
    Distro
    Ubuntu 6.06 Dapper

    Re: Unreal Tournament GOTY sound quality issues

    Hi

    Dapper 6.06
    Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 04)

    I think I've got the same problem with both UT GOTY and UT 2004.

    If I run ut directly I get no sound. If I run with esddsp I get strange warped half speed sound. If I run via aoss I get screeching noise.

    Anyone got any further sorting this out?
    Homepage: munckfish.net

  9. #9
    Join Date
    Jun 2006
    Location
    South Africa
    Beans
    635
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Unreal Tournament GOTY sound quality issues

    I'm beginning to think this is a problem with snd-hda-intel, and not with UT's libs. I'm having the same problem with the original Unreal, BTW. Only thing is, I recompiled ALSA a while ago and it didn't help. Perhaps we should file a bug report over at the ALSA page?
    Intel 3.2Ghz Prescott | 1024MB DDR2 533Mhz | Intel GEV915 Motherboard | GeForce 8600GT
    Registered Linux User #422029
    Name the next release Dodgy Duck!

  10. #10
    Join Date
    Jul 2006
    Location
    Trelleborg-Sweden
    Beans
    55
    Distro
    Kubuntu 8.10 Intrepid Ibex

    Re: Unreal Tournament GOTY sound quality issues

    And I just got UT running native... got the same issue as you guys..

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •