Results 1 to 10 of 14

Thread: HOWTO: Solution for EDID Resolution Problems

Hybrid View

  1. #1
    Join Date
    Nov 2004
    Beans
    30
    Distro
    Ubuntu 9.10 Karmic Koala

    HOWTO: Solution for EDID Resolution Problems

    This HOWTO is for problems related to incorrect resolutions resulting from EDID problems. In other words, your video card is unable to detect the correct EDID settings from your monitor, at the fault of your video card driver. I tested this with my Nvidia GeForce MX440 Go.

    As I cannot take credit for the solution, here is a link to the original post at nVnews forums:
    http://www.nvnews.net/vbulletin/show...2&postcount=26

    Please note that unless you know what you are doing, your /etc/X11/xorg.conf file should be the standard one generated by the driver installation.

    Procedure:

    1. Download Phoenix EDID Designer.
    2. If you're able to run Windows, use windows to run this program, otherwise use Wine. I'm not sure if it works 100% using Wine, so refer to the original post.
    3. In Phoenix EDID Designer, click "Tools > Extract Registry EDID".
    4. Click on the listing that appears, then click "Extract EDID"
    5. Click "File > Export" and save your file as a ".raw" file.
    6. Copy your file to the /etc/X11/ directory:
      Code:
      sudo cp EDID_FILE.raw /etc/X11/
    7. Edit your xorg.conf:
      Code:
      sudo gedit /etc/X11/xorg.conf
      And, add the following option lines to the "device" section
      Code:
          
      #Option      "AddARGBGLXVisuals" "true" #NVidia specific, uncomment if needed
      #Option      "UseDisplayDevice" "DFP-0" #Uncomment and modify if needed
      Option      "CustomEDID" "DFP-0:/etc/X11/nvnew.raw"
    8. Save the file, close gedit and press "CTRL ALT BACKSPACE" to restart X.

  2. #2
    Join Date
    Aug 2006
    Location
    Messina, Italy
    Beans
    98
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: HOWTO: Solution for EDID Resolution Problems

    There is a couple of other threads on http://www.nvnews.net dealing geforce4 fix with custom EDID. You could check also http://www.nvnews.net/vbulletin/showthread.php?t=81635 which has a detail explanation of the steps and a couple of ready custom_edid.bin files.

    Hope this can help you

    catanzag
    Registered Linux User #426115
    My personal blog

  3. #3
    Join Date
    Dec 2006
    Location
    Cambridge, ON, Canada
    Beans
    112
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: Solution for EDID Resolution Problems

    you are my hero.

    ++1

  4. #4
    Join Date
    May 2010
    Beans
    3

    Re: HOWTO: Solution for EDID Resolution Problems

    Anyone still active around here? I really need this to work, but I don't find my xorg.conf running Ubuntu 10.04.

    Please help!

  5. #5
    Join Date
    Sep 2007
    Location
    Oklahoma, USA
    Beans
    2,256
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: HOWTO: Solution for EDID Resolution Problems

    I'm running 10.04 also and no xorg.conf file was created by default. However, you can create one in the /etc/X11 directory and it will be used. Tell us more about your specific video card and monitor, and we can tell you what to put into such a file.
    Last edited by JKyleOKC; November 21st, 2011 at 06:36 PM. Reason: Corrected file name to all lower case.
    --
    Jim Kyle in Oklahoma, USA
    Linux Counter #259718
    Howto mark thread: https://wiki.ubuntu.com/UnansweredPo.../SolvedThreads

  6. #6
    Join Date
    May 2010
    Beans
    3

    Re: HOWTO: Solution for EDID Resolution Problems

    Hi!

    I managed to create the file now, and put the line concerning the EDID in it, but nothing changes. The file is in the correct place, but I'm not sure if I inserted the CustomEDID stuff correctly.

    The computer has a S3 video card and the screen is an acer V223HQ with max. resolution of 1920x1080.

    More about the whole problem here: http://www.linuxforums.org/forum/ubu...tml#post870153

  7. #7
    Join Date
    Jan 2014
    Beans
    4

    Re: HOWTO: Solution for EDID Resolution Problems

    Hi, I'm hoping I can bump this and get some help.

    The Phoenix EDID tool didn't work on my system. Error during install on win 7. I found a cmd line program Dump EDID and was able to extract some info. It looks like both Win 7 and Nvidia X server are pulling the same EDID info.

    I'm using a Panasonic TC-L32X5 TV. I found a modeline for a TX-32LXD52 on Myth TV. The reason I chose that one is to get the screen to fit in X Server I have to do viewport out at 1216x684. I can't find much literature on the TC-L32X5 TV, but what I can find says its native resolution is 1366x768 16:9 aspect ratio. This is the modeline I'm using from MythTV - Modeline "1216x684p60" 74.160 1216 1356 1396 1648 684 707 712 750 +hsync +vsync


    I get this in my xorg.0.log:

    Panasonic-TV (DFP-1)'s EDID does not contain a maximum image size; cannot compute DPI from Panasonic-TV (DFP-1)'s EDID. DPI set to (75, 75); computed from built-in default


    Dump EDID output this:

    EDID Version : 1.3
    Display Gamma : 2.20
    Vertical Frequency : 23 - 61 Hz
    Horizontal Frequency : 15 - 68 KHz
    Image Size : 69.8 X 39.2 cm (31.5 Inch)
    Maximum Resolution : 0 X 0
    Support Standby Mode : No
    Support Suspend Mode : No
    Support Low-Power Mode : No
    Support Default GTF : No
    Digital : Yes

    Maximum Resolution says 0x0?

    Vetrical and horizontal freq. do match whats in my xorg.conf

  8. #8
    Join Date
    Jan 2014
    Beans
    4

    Re: HOWTO: Solution for EDID Resolution Problems

    Okay, just in case anyone has a similar problem as myself.


    in my xorg.conf adding these lines to Section "Device" :

    Option "ModeValidation" "NoVesaModes, NoXServerModes"
    Option "UseDisplayDevice" "DFP-1"
    Option "ModeDebug" "true"

    This will force all the modes from the EDID and then validate them to find ones that are valid for your system. My display device is on DFP-1





    There are a couple choices you can choose a resolution from the validated modes for your display. One of mine is "1280x720_60_0" , or use "nvidia-auto-select". After you add the options from above, check the log file xorg.0.log it will tell you the accepted modes.


    Adding this option to the Section "Screen":

    Option "metamodes" "nvidia-auto-select" OR "your resolution" I've tried using both and they work.





    If you have a underscan or overscan problem then changing the "viewportout=" will fix the problem. I checked the nvidia control panel in Win 7 and I have to have the same info in Win7 for the desktop to fit in screen. It resizes my desktop to 1216x684.

    My line from Section "Screen" is:

    Option "metamodes" "nvidia-auto-select +0+0 {viewportin=1280x720, viewportout=1216x684+32+18}"

    My desktop fits in the screen at 1216x684. My native resolution is 1280x720. The viewportout resolution needs to maintain the correct aspect ratio or XServer will throw it out.
    (1280-1216=64/2=32)
    (720-684=36/2=18)
    The +32+18 is telling XServer to shift the display right by 32 pixels and up by 18 pixels so that the desktop is centered within the screen.




    For the DPI I forced it under Section "Monitor"
    Option "UseEdidDpi" "FALSE"
    Option "DPI" "96 x 96"

    My fonts are too small at 75x75.
    Last edited by novarcr; January 4th, 2014 at 03:31 AM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •