Results 1 to 10 of 21

Thread: Intel Pro/Wireless 2200BG [Resolved]

Hybrid View

  1. #1
    Join Date
    Nov 2006
    Location
    Salt Lake City, UT
    Beans
    45
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Intel Pro/Wireless 2200BG [Resolved]

    Hey all,

    I'm new to this forum and didn't even know a Utah LUG existed! Well, that's good news for all of us.

    I'm a Linux newbie (today is my Linux debut) and am experiencing my first roadblock.

    I'm having difficulty getting my Ubuntu (Eggy) box to connect to the 'net with my Intel Pro/Wireless 2200BG wifi card. I've googled and read numerous HOW-TOs without any success. There's so much information out there that it's hard to tell which is the right one to go with.

    I don't know where to start or what information you'll need to help me fix this speedbump, so please be patient.

    Where do we start?

    Thanks in advance for all of your help.

    Frijolie
    Holladay, UT

  2. #2
    Join Date
    Nov 2006
    Location
    Salt Lake City, UT
    Beans
    45
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Intel Pro/Wireless 2200BG

    with some more googling, I found some frequently requested outputs. Here they are and hope they help...

    Code:
    brian@brian-laptop:~$ sudo iwconfig
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    
    eth1      unassociated  ESSID:off/any  
              Mode:Managed  Channel=0  Access Point: Not-Associated   
              Bit Rate:0 kb/s   Tx-Power=20 dBm   Sensitivity=8/0  
              Retry limit:7   RTS thr:off   Fragment thr:off
              Encryption key:off
              Power Management:off
              Link Quality:0  Signal level:0  Noise level:0
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    
    sit0      no wireless extensions.
    and

    Code:
    brian@brian-laptop:~$ sudo lshw -C network
    Password:
      *-network:0             
           description: Ethernet interface
           product: RTL-8139/8139C/8139C+
           vendor: Realtek Semiconductor Co., Ltd.
           physical id: 1
           bus info: pci@02:01.0
           logical name: eth0
           version: 10
           serial: 00:0f:b0:5a:c2:1f
           size: 100MB/s
           capacity: 100MB/s
           width: 32 bits
           clock: 33MHz
           capabilities: bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegociation
           configuration: autonegociation=on broadcast=yes driver=8139too driverversion=0.9.27 duplex=full ip=192.168.1.105 link=yes multicast=yes port=MII speed=100MB/s
           resources: ioport:4000-40ff iomemory:d0201800-d02018ff irq:217
      *-network:1
           description: Wireless interface
           product: PRO/Wireless 2200BG Network Connection
           vendor: Intel Corporation
           physical id: 2
           bus info: pci@02:02.0
           logical name: eth1
           version: 05
           serial: 00:0e:35:c9:05:db
           width: 32 bits
           clock: 33MHz
           capabilities: bus_master cap_list ethernet physical wireless
           configuration: broadcast=yes driver=ipw2200 driverversion=1.1.2kmprq firmware=ABG:9.0.2.6 (Mar 22 2005) link=no multicast=yes wireless=unassociated
           resources: iomemory:d0200000-d0200fff irq:225
    Hope this has helped..

  3. #3
    Join Date
    Apr 2006
    Location
    Houston Texas, USA
    Beans
    52
    Distro
    Ubuntu 6.10 Edgy

    Re: Intel Pro/Wireless 2200BG

    Well, first of all welcome to the Ubuntu community!

    Are you trying to connect to a WEP secured router or a WPA secured router? If you are trying to connect to a WEP secured router, then you should go to System->Administration->Networking, where you should see your 'wireless connection.' It should be there, since your eth1 connection is showing wireless stuff. There you can click properties and enter your router info ( SSID, and ASCII passphrase ( or Hex 64 or 128 key ) and it should configure it for you. A program i like to use is wifi-radar, it makes automatic switching between wireless profiles a very easy task. You should give it a try after you get everything working.
    I'm not totally sure how to connect to WPA with edgy, but i just got it working tonight on dapper, so you might need to look around a little.

    I hope this helps, and let me know if i can help out anymore.

  4. #4
    Join Date
    Nov 2006
    Location
    Salt Lake City, UT
    Beans
    45
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Intel Pro/Wireless 2200BG

    thanks for trying to help...

    I'm using WPA+PSK 128bit security. I installed gtkwifi-1.09 and when I mouse over the icon in the 'notification area' it says "X amount of networks" (where X is the amount of wireless networks available) but when I click on the icon it doesn't show any wireless networks in the window.

    I've typed in my SSID and passkey manually in System --> Administration --> Networking and it doesn't connect. Hmmmm..I don't know where to go from here..

  5. #5
    Join Date
    May 2005
    Location
    Seattle, WA
    Beans
    250
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Intel Pro/Wireless 2200BG

    I dont live in Utah, but i use wifi-radar for my wifi. I dont know if it supports WPA-PSK though.
    "If you are savvy and smart about the choices you make in life, The sky is not the limit!" - Mark Shuttleworth
    This message has been rot 26 encrypted for security reasons.

  6. #6
    Join Date
    Nov 2006
    Beans
    2

    Re: Intel Pro/Wireless 2200BG

    Edgy does not support WPA out of the box, however it is an easy fix. Here is the link that I used to get it working. I have the same card in my laptop.
    http://www.debianadmin.com/enable-wp...ntu-linux.html

    Let us know how it goes.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •