Results 1 to 10 of 20

Thread: UEFI Motherboard dual boot/dual HDD

Hybrid View

  1. #1
    Join Date
    Jul 2007
    Beans
    28

    Question UEFI Motherboard dual boot/dual HDD

    I have a UEFI motherboard (Gigabyte GA Z77MX-D3H) and a 120GB SSD and 2TB HDD.

    Here is my current config:
    sda 120GB SSD
    sda1 ntfs 100MB Windows boot partition
    sda2 ntfs 70GB Windows partition
    sda3 ext4 40GB Xubuntu / partition
    sdb 2TB HDD
    sdb1 ntfs 1500GB Storage partition
    sdb2 swap 10GB Linux-swap
    sdb3 ext2 500MB Xubuntu /boot partition
    sdb4 ext4 300GB Xubuntu /home partition
    Bootloader installed to sdb in Xubuntu installer

    However, I cannot boot Xubuntu. Only the windows BCD bootloader ever appears. Even leaving default option and installing bootloader to sda doesn't work. Its always the Windows bootloader appearing.

    I have tried booting from the 2TB HDD where I expect the MBR for GRUB2 will be installed from the installer but it just goes on to the Windows bootloader as if it couldn't find GRUB.

    I have tried adding Xubuntu to the Windows BCD to chainload with EasyBCD but it just reverts straight to Grub4Dos prompt.

    I think my motherboard being UEFI is relevant somewhere. I am unsure of what UEFI is in comparison to BIOS.



    What configuration do I take to get this dual-boot up and running? I would prefer Xubuntu OS to be on the SSD and /home to be on the HDD.

    Thanks

  2. #2
    Join Date
    Jan 2013
    Beans
    51

    Re: UEFI Motherboard dual boot/dual HDD

    I don't know what UEFI is but, you should see look at your HHD and see if the one is set to master and the other one slave, or they could both be set to master, not sure if this is the problem but it would not hurt to see if this could be the problem.
    If this is the problem check this it, it will tell you were to put the pins on your HHD

    http://en.wikipedia.org/wiki/Master/slave_(technology)

  3. #3
    Join Date
    Jul 2007
    Beans
    28

    Re: UEFI Motherboard dual boot/dual HDD

    Quote Originally Posted by 101kitty View Post
    I don't know what UEFI is but, you should see look at your HHD and see if the one is set to master and the other one slave, or they could both be set to master, not sure if this is the problem but it would not hurt to see if this could be the problem.
    If this is the problem check this it, it will tell you were to put the pins on your HHD

    http://en.wikipedia.org/wiki/Master/slave_(technology)
    With SATA hard disks there is no master/slave afaik.

    UEFI is some new replacement for BIOS that released last year. It allows faster booting and Windows 8 requires it but it has booting complications.

  4. #4
    Join Date
    Mar 2008
    Location
    USA, WA
    Beans
    79
    Distro
    Kubuntu

    Smile Re: UEFI Motherboard dual boot/dual HDD

    UEFI has a feature known as "secure boot" which blocks out any other boot loaders or operating systems. So try to hit your F key to enter that EFI set up screen to find and disable secure boot if that is available as an option. Here are some UEFI web sites links here; http://www.uefi.org/about/,and here; http://en.wikipedia.org/wiki/Unified...ware_Interface , and this one too; http://www.extremetech.com/computing...os-replacement

  5. #5
    Join Date
    Jul 2007
    Beans
    28

    Re: UEFI Motherboard dual boot/dual HDD

    Quote Originally Posted by james2b View Post
    UEFI has a feature known as "secure boot" which blocks out any other boot loaders or operating systems. So try to hit your F key to enter that EFI set up screen to find and disable secure boot if that is available as an option. Here are some UEFI web sites links here; http://www.uefi.org/about/,and here; http://en.wikipedia.org/wiki/Unified...ware_Interface , and this one too; http://www.extremetech.com/computing...os-replacement
    My MB manual doesn't document anything like this. I did however find an more than 4 options under "CSM Support" that could be "Legacy only", "UEFI only", "UEFI and Legacy". One of those options called "Boot mode support". Is this relevant?

    I set CSM Support to Never instead of Always as an experiment and the computer did long beep and no response. Had to reset CMOS. So that isn't the option obviously...


    Now, do you have any answers to the OP's question?

  6. #6
    Join Date
    Mar 2008
    Location
    USA, WA
    Beans
    79
    Distro
    Kubuntu

    Smile Re: UEFI Motherboard dual boot/dual HDD

    Search that Gigabyte motherboard web site for more specific information such as CSM, this motherboard here may be yours; http://www.gigabyte.us/products/prod...px?pid=4145#ov , and here; http://www.tomshardware.com/forum/347038-28-support Did that computer come with Windows 8 originally, and what brand PC ?

  7. #7
    Join Date
    Jul 2007
    Beans
    28

    Re: UEFI Motherboard dual boot/dual HDD

    Quote Originally Posted by james2b View Post
    Search that Gigabyte motherboard web site for more specific information such as CSM, this motherboard here may be yours; http://www.gigabyte.us/products/prod...px?pid=4145#ov , and here; http://www.tomshardware.com/forum/347038-28-support Did that computer come with Windows 8 originally, and what brand PC ?
    Thanks for the help but if you read the OP you would see that I know what motherboard I have. Because I built the PC from new parts (i5 3570K, GTX 670 etc.). And there is nothing to do with Windows 8, this is for trying to get to Xubuntu's GRUB menu (I have Windows 7 btw).

    Thanks

  8. #8
    Join Date
    Feb 2010
    Beans
    10

    Re: UEFI Motherboard dual boot/dual HDD

    Your problem is a known issue with booting to an SSD from a Gigabyte motherboard. Try changing the SATA ports to AHCI in the BIOS settings and then reboot. Also, if you are normally booting to the SSD, you would want the SSD to be placed before the other HDD in the BIOS menu for setting the device boot order.

  9. #9
    Join Date
    Jul 2007
    Beans
    28

    Re: UEFI Motherboard dual boot/dual HDD

    Quote Originally Posted by dsv47 View Post
    Your problem is a known issue with booting to an SSD from a Gigabyte motherboard. Try changing the SATA ports to AHCI in the BIOS settings and then reboot. Also, if you are normally booting to the SSD, you would want the SSD to be placed before the other HDD in the BIOS menu for setting the device boot order.
    It was at AHCI by default. And boot order is SSD first.

  10. #10
    Join Date
    Jul 2007
    Beans
    28

    Re: UEFI Motherboard dual boot/dual HDD

    Here's some progress:

    Fedora 17 boots fine with chainloader +1 from Grub4Dos.
    Yet with Xubuntu it says "Unsupported executable format".

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •