Results 1 to 10 of 26

Thread: Wacom tablet kernel issues

Hybrid View

  1. #1
    Join Date
    Dec 2012
    Beans
    15

    Wacom tablet kernel issues

    First, I know there are posts and pages all over that describe how to do this, but none of them have worked for me because of this.
    So,
    HTML Code:
    http://ubuntuforums.org/showthread.php?t=1515562
    . When going through step 1 compiling the driver, I get all the way down to "./configure --prefix=/usr". When I input that, I get this error:

    make[1]: Entering directory `/home/user/Desktop/input-wacom-0.13.0'
    make[2]: Entering directory `/home/user/Desktop/input-wacom-0.13.0'
    make[2]: Leaving directory `/home/user/Desktop/input-wacom-0.13.0'
    make[1]: Leaving directory `/home/user/Desktop/input-wacom-0.13.0'

    ----------------------------------------
    BUILD ENVIRONMENT:
    linux kernel - yes
    kernel source - no

    We could not find the kernel development environment to build the driver.
    Please install the kernel source or the kernel development package and try again.

    I am currently running Ubuntu 11.04 fresh install. I first tried the same process along with some PPA's on 12.10, 11.10 and now 11.04. I've gotten the same errors across the board, so I want to figure out what I need to do. Thanks!
    Last edited by Cdraam; December 7th, 2012 at 06:00 AM.

  2. #2
    Join Date
    Jul 2012
    Location
    Cincinnati, OH
    Beans
    179
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: Wacom tablet kernel issues

    Have you read through this?

    https://help.ubuntu.com/community/Kernel/Compile

    What exactly are you trying to compile?
    Best,
    Lev

    [Personal Blog]

  3. #3
    Join Date
    Dec 2012
    Beans
    15

    Re: Wacom tablet kernel issues

    The USB Kernel drive I believe.
    Out of the box it won't run the 3rd gen tablets, but when you get the 3.3 kernel it does. I'm really unfamiliar with Linux, so excuse me if I'm not making sense.

  4. #4
    Join Date
    Nov 2008
    Beans
    9,635
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Wacom tablet kernel issues

    Hi Cdraam,

    Welcome to Ubuntu forums!


    Looks like you skipped a step, probably the linux-headers one.

    I don't know about Natty 11.04 as a choice for release as it is past its 18 month support period so it is no longer supported.

    Also the HOW TO isn't updated so there are newer versions of input-wacom and xf86-input-wacom. See the update post: http://ubuntuforums.org/showpost.php...postcount=1081

    Or you could use this updated HOW TO.

    Please feel free to ask if you have more questions.

  5. #5
    Join Date
    Dec 2012
    Beans
    15

    Re: Wacom tablet kernel issues

    I chose Natty because with the other two versions it did the same thing. and on the Howto there are 3(?) PPA's that only went as high as Natty. So I decided to move back to that after the other two obviously weren't going to work.
    I don't have time until later to try the updated howto, but what about the kernel issue I have? I didn't skip the kernel headers step. Like I've said, I've done the whole process probably 6 times now, through all the Ubuntu versions.
    I should add, it doesn't only bring up the kernel issue on the compiling, I found one of the PPA's he lists and tried it and it came up with a similar error at the end.
    Last edited by Cdraam; December 7th, 2012 at 04:50 PM.

  6. #6
    Join Date
    Nov 2008
    Beans
    9,635
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Wacom tablet kernel issues

    OK, What's the output of this command in a terminal?
    Code:
    uname -a
    I should add, it doesn't only bring up the kernel issue on the compiling, I found one of the PPA's he lists and tried it and it came up with a similar error at the end.

    BUILD ENVIRONMENT:
    linux kernel - yes
    kernel source - no

    We could not find the kernel development environment to build the driver.
    Please install the kernel source or the kernel development package and try again.
    I don't remember that being a problem with input-wacom-0.13.0. Although there have been occasional build problems in specific instances that have been fixed so it would be interesting if that happens with 0.15.0 too.

    Is it complaining about build-essential not being installed? When you run the library/dependency line:
    Code:
    sudo apt-get install build-essential libx11-dev libxi-dev x11proto-input-dev xserver-xorg-dev libxrandr-dev libncurses5-dev autoconf libtool
    you're getting the whole thing and it isn't complaining or throwing errors?

    Another thought is with Update Manager open Settings on the bottom left. Is Source code checked in the Ubuntu software tab?
    Last edited by Favux; December 7th, 2012 at 11:38 PM. Reason: Copied the wrong dependency line.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •